lirc: Update. This fixes compile on 2.6.36
[openwrt/svn-archive/archive.git] / net / wiviz / Makefile
index e0e1b2d1f513f958f0bb5b8f0fb12208ce411231..fcc202054c5c70769b4b480d0c734df38f6e7a69 100644 (file)
@@ -1,10 +1,9 @@
 #
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2009 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
@@ -12,8 +11,6 @@ PKG_NAME:=wiviz
 PKG_VERSION:=1.0
 PKG_RELEASE:=1
 
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-
 include $(INCLUDE_DIR)/package.mk
 
 define Package/wiviz
@@ -29,16 +26,19 @@ define Build/Prepare
        $(CP) ./src/* $(PKG_BUILD_DIR)/
 endef
 
+EXTRA_CFLAGS += $(TARGET_CPPFLAGS)
+EXTRA_LDFLAGS += $(TARGET_LDFLAGS)
+
 define Build/Compile
        $(call Build/Compile/Default, \
                CCOPTS="$(TARGET_CFLAGS)" \
-               INCLUDE="$(EXTRA_CPPFLAGS)" \
+               INCLUDE="$(EXTRA_CFLAGS)" \
                LDFLAGS="$(EXTRA_LDFLAGS)" \
        )
 endef
 
 define Package/wiviz/install   
-       mkdir -p $(1)/usr/sbin
+       $(INSTALL_DIR) $(1)/usr/sbin
        $(CP) $(PKG_BUILD_DIR)/$(PKG_NAME) $(1)/usr/sbin/
        $(CP) ./files/* $(1)
        find $(1) -name CVS | xargs rm -rf