[packages] tor-alpha: update to 0.2.2.22-alpha, add archive mirror
[openwrt/svn-archive/archive.git] / net / wput / Makefile
index 30721cb3c76196304d1593fb286d99574444f4c0..bb0c325b49a6c3ef10d84889b89cf9814e6019f6 100644 (file)
@@ -1,46 +1,44 @@
-# 
-# Copyright (C) 2006 OpenWrt.org
+#
+# Copyright (C) 2007-2008 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=wput
-PKG_VERSION:=0.5
+PKG_VERSION:=0.6.2
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tgz
 PKG_SOURCE_URL:=@SF/wput
-PKG_MD5SUM:=441b2e07219f78167b29a7ac33488fff
-PKG_CAT:=zcat
-
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)
+PKG_MD5SUM:=a14c4c13d91d04d6119bdc977e8a8bdf
 
 include $(INCLUDE_DIR)/package.mk
 
 define Package/wput
+  SUBMENU:=FTP
   SECTION:=net
   CATEGORY:=Network
-  TITLE:=A wget-like command-line FTP client
-  URL:=http://itooktheredpill.dyndns.org/wput/
+  TITLE:=A tiny wget-like ftp-client for uploading files
+  URL:=http://wput.sourceforge.net/
 endef
 
-define Build/Configure
-       $(call Build/Configure/Default, \
-               --disable-g-switch \
-       )
+define Package/wput/description
+ Wput is a tiny ftp-client, that uploads files or directories
+ to a remote ftp-server.  Main features are: resuming,
+ time-stamping, wget-like interface, proxy-support and
+ speed-limit.
 endef
 
-define Build/Compile
-       $(MAKE) -C $(PKG_BUILD_DIR)
-endef
+CONFIGURE_ARGS += \
+       --disable-g-switch \
+       --without-ssl \
 
 define Package/wput/install
-       install -d -m0755 $(1)/usr/bin
-       install -m0755 $(PKG_BUILD_DIR)/wput $(1)/usr/bin/
+       $(INSTALL_DIR) $(1)/usr/bin
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/wput $(1)/usr/bin/
 endef
 
 $(eval $(call BuildPackage,wput))