Add vnstati (#4311)
[openwrt/svn-archive/archive.git] / net / wrt-radauth / Makefile
index b0e16462ced53f19690044cfe5408ff8a434e7e7..5ab8ece62f810174c2d1ffce8942618664d9e2fa 100644 (file)
@@ -9,13 +9,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=wrt-radauth
-PKG_VERSION:=1.0
+PKG_VERSION:=0.1
 PKG_RELEASE:=1
 
-PKG_SOURCE:=$(PKG_NAME).tar.gz
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://www.zerfleddert.de/wrt54g/
-PKG_MD5SUM:=f941e3139175dc6b87f6c89ba8848a07
-PKG_CAT:=zcat
+PKG_MD5SUM:=1713b96a157f9e209cf7986f38ef57d9
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)
 
@@ -24,16 +23,19 @@ include $(INCLUDE_DIR)/package.mk
 define Package/wrt-radauth
   SECTION:=net
   CATEGORY:=Network
-  DEPENDS:=kmod-brcm-wl +nvram
+  DEPENDS:=+kmod-brcm-wl +nvram
   TITLE:=A Radius MAC authenticator for Broadcom based access points
-  DESCRIPTION:=\
-       This software watches the stations associating to a broadcom based \\\
-       AccessPoint (e.g. Linksys WRT54G) and sends an authentication request \\\
-       to the radius-server specified in nvram.
   URL:=http://www.zerfleddert.de/wrt54g/
 endef
+
+define Package/wrt-radauth/description
+       This software watches the stations associating to a broadcom based 
+       AccessPoint (e.g. Linksys WRT54G) and sends an authentication request 
+       to the radius-server specified in nvram.
+endef
   
 define Build/Compile
+       $(MAKE) -C $(PKG_BUILD_DIR) clean
        $(call Build/Compile/Default, \
                CFLAGS="$(EXTRA_CFLAGS)" \
                LDFLAGS="$(EXTRA_LDFLAGS)" \