packages: add missing conffiles define
[openwrt/svn-archive/archive.git] / net / wshaper / Makefile
index 1f02f0b5dad829488702873b517c9c3ea3ee0e06..2c73705ef5dc5d65b50c07e3d9c2cd317cf6a175 100644 (file)
@@ -1,15 +1,15 @@
 # 
-# Copyright (C) 2007 OpenWrt.org
+# Copyright (C) 2007-2011 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id: $
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=wshaper
-PKG_VERSION:=0.1
+PKG_VERSION:=0.2
+PKG_RELEASE:=2
 
 PKG_BUILD_DIR := $(BUILD_DIR)/$(PKG_NAME)
 
@@ -21,6 +21,7 @@ define Package/wshaper
   DEPENDS:=+kmod-sched +tc
   TITLE:=wshaper
   URL:=http://lartc.org/wondershaper/
+  PKGARCH:=all
 endef
 
 define Package/wshaper/description
@@ -41,9 +42,14 @@ define Build/Compile
 endef
 
 define Package/wshaper/install
-       $(INSTALL_DIR) $(1)/usr/sbin/
+       $(INSTALL_DIR) $(1)/usr/sbin/ $(1)/etc/init.d $(1)/etc/config
        $(INSTALL_BIN) ./files/wshaper.htb $(1)/usr/sbin/
        $(INSTALL_BIN) ./files/wshaper.init $(1)/etc/init.d/wshaper
+       $(INSTALL_DATA) ./files/wshaper.config $(1)/etc/config/wshaper
+endef
+
+define Package/wshaper/conffiles
+/etc/config/wshaper
 endef
 
 $(eval $(call BuildPackage,wshaper))