[PATCH] Wondershaper uci config and modules fix
[openwrt/svn-archive/archive.git] / net / wshaper / Makefile
index 691d2633de7baf5e7bd680a318e0b880ca506d2e..5ea1bc92a939ace5c04c57cc424604c273b71753 100644 (file)
@@ -4,12 +4,11 @@
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id: $
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=wshaper
-PKG_VERSION:=0.1
+PKG_VERSION:=0.2
 
 PKG_BUILD_DIR := $(BUILD_DIR)/$(PKG_NAME)
 
@@ -21,6 +20,7 @@ define Package/wshaper
   DEPENDS:=+kmod-sched +tc
   TITLE:=wshaper
   URL:=http://lartc.org/wondershaper/
+  PKGARCH:=all
 endef
 
 define Package/wshaper/description
@@ -41,8 +41,10 @@ define Build/Compile
 endef
 
 define Package/wshaper/install
-       $(INSTALL_DIR) $(1)/usr/sbin/
+       $(INSTALL_DIR) $(1)/usr/sbin/ $(1)/etc/init.d
        $(INSTALL_BIN) ./files/wshaper.htb $(1)/usr/sbin/
+       $(INSTALL_BIN) ./files/wshaper.init $(1)/etc/init.d/wshaper
+       $(INSTALL_DATA) ./files/wshaper.config $(1)/etc/config/wshaper
 endef
 
 $(eval $(call BuildPackage,wshaper))