Upgrade xl2tpd to 1.1.12 (#3670)
[openwrt/svn-archive/archive.git] / net / xl2tpd / Makefile
index 02862e3e0256352954b978837dd894c3b5257289..077fca2741e1ed919ded1986e01816e16e4bad20 100644 (file)
@@ -4,20 +4,17 @@
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id: Makefile 5624 2006-11-23 00:29:07Z nbd $
+# $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=xl2tpd
-PKG_VERSION:=1.1.09
-PKG_RELEASE:=1.0
+PKG_VERSION:=1.1.12
+PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://www.xelerance.com/software/xl2tpd
-PKG_CAT:=zcat
-
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+PKG_MD5SUM:=8ace771a29139485c0edf428091cad5d
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -25,36 +22,37 @@ define Package/xl2tpd
   SECTION:=net
   CATEGORY:=Network
   TITLE:=An L2TP (Layer 2 Tunneling Protocol) daemon
-  DESCRIPTION:=\
-       l2tpd is the open source implementation of the L2TP tunneling \\\
-       protocol (RFC2661). It does implement both LAC and LNS role \\\
-       in a L2TP networking architecture. The main goal of this protocol is \\\
-       to tunnel PPP frame trough an ip network.
   URL:=http://www.xelerance.com/software/xl2tpd
+  SUBMENU:=VPN
 endef
 
-define Package/xl2tpd/conffiles
-/etc/xl2tpd/xl2tpd.conf
+define Package/xl2tpd/description
+ l2tpd is the open source implementation of the L2TP tunneling protocol
+ (RFC2661). It does implement both LAC and LNS role in a L2TP networking
+ architecture. The main goal of this protocol is to tunnel PPP frame trough
+ an ip network.
 endef
 
-define Build/Compile
-       $(call Build/Compile/Default, \
-               CFLAGS="$(TARGET_CFLAGS) -I. -DLINUX -DSANITY -DIP_ALLOCATION" \
-       )
+# XXX: CFLAGS are already set by Build/Compile/Default
+MAKE_FLAGS+= \
+       OFLAGS=""
+
+define Package/xl2tpd/conffiles
+/etc/xl2tpd/ppp.options
+/etc/xl2tpd/ppp.secrets
+/etc/xl2tpd/xl2tpd.conf
 endef
 
 define Package/xl2tpd/install  
        $(INSTALL_DIR) $(1)/usr/sbin
-       $(INSTALL_BIN) $(PKG_BUILD_DIR)/$(PKG_NAME) $(1)/usr/sbin/
-       $(INSTALL_DIR) $(1)/etc/xl2tpd
-       $(INSTALL_DATA) ./files/xl2tpd.conf $(1)/etc/xl2tpd/
-       $(INSTALL_DATA) ./files/l2tp-secrets $(1)/etc/xl2tpd/
-       $(INSTALL_DATA) ./files/options.l2tp $(1)/etc/xl2tpd/
-#      $(INSTALL_DIR) $(1)/etc/ppp
-#      $(INSTALL_DATA) ./files/options.l2tpd $(1)/etc/ppp/
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/xl2tpd $(1)/usr/sbin/
        $(INSTALL_DIR) $(1)/etc/init.d
        $(INSTALL_BIN) ./files/xl2tpd.init $(1)/etc/init.d/xl2tpd
+       $(INSTALL_DIR) $(1)/etc/xl2tpd
+       $(INSTALL_DATA) ./files/ppp.options $(1)/etc/xl2tpd/
+       $(INSTALL_DATA) ./files/ppp.secrets $(1)/etc/xl2tpd/
+       $(INSTALL_DATA) ./files/xl2tpd.conf $(1)/etc/xl2tpd/
+       chmod 0600 $(1)/etc/xl2tpd/ppp.secrets
 endef
 
 $(eval $(call BuildPackage,xl2tpd))
-