fix multi-packages builds, cleanup
[openwrt/svn-archive/archive.git] / net / xmail / Makefile
index 03b3b14bcd613cf1be8fb034c561c37fc0fe20f9..04dbe94e818bea89742489b3f2328271f28d65f0 100644 (file)
@@ -12,13 +12,9 @@ PKG_NAME:=xmail
 PKG_VERSION:=1.24
 PKG_RELEASE:=1
 
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://www.xmailserver.org/
 PKG_MD5SUM:=106730bdbaa4fda9e90a7c22df024114
-PKG_CAT:=zcat
-
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -27,25 +23,27 @@ define Package/xmail
   CATEGORY:=Network
   DEPENDS:=+uclibcxx +libopenssl
   TITLE:=advanced, fast and reliable ESMTP/POP3 mail server
-  DESCRIPTION:=\
-       XMail is an Internet mail server featuring an SMTP, POP3 and finger server. \\\
-       It's incredibly easy to set up and has lots of features including : \\\
-       multiple domains, virtual users and spam protection.
   URL:=http://www.xmailserver.org/
 endef
 
+define Package/xmail/description
+ XMail is an Internet mail server featuring an SMTP, POP3 and finger server. 
+ It's incredibly easy to set up and has lots of features including : 
+ multiple domains, virtual users and spam protection.
+endef
+
 define Build/Configure
        $(CP) ./files/SysMachine.h $(PKG_BUILD_DIR)/
 endef
 
 define Build/Compile
+       CFLAGS="$(TARGET_CFLAGS)" \
        $(MAKE) -C $(PKG_BUILD_DIR) -f Makefile.lnx \
                $(TARGET_CONFIGURE_OPTS) \
-               LDFLAGS="$(EXTRA_LDFLAGS) -luClibc++ -lssl -lm -lpthread -lcrypto -ldl" \
-               WITH_SSL_INCLUDE="$(STAGING_DIR)/usr/include" \
-               WITH_SSL_LIB="$(STAGING_DIR)/usr/lib" \
-               CPPFLAGS="$(TARGET_CFLAGS)" \
-               CXX="$(TARGET_CROSS)g++"
+               LD="\$$$$(CC)" \
+               CPPFLAGS="$(TARGET_CPPFLAGS) -I$(STAGING_DIR)/usr/include/uClibc++ -fno-builtin -fno-rtti -nostdinc++" \
+               LDFLAGS="$(TARGET_LDFLAGS) -nodefaultlibs -lcrypto -lssl -luClibc++ -ldl -lm -lpthread" \
+               all
 endef
 
 define Package/xmail/install