replace lots of manual install commands with INSTALL_* variables
[openwrt/svn-archive/archive.git] / net / xsupplicant / Makefile
index e7b01ac3ae0fd34dc4e2747bea50396bedf90b65..dcbc3441486c35df0bbe5d9df4431684c103e698 100644 (file)
@@ -11,15 +11,17 @@ include $(TOPDIR)/rules.mk
 PKG_NAME:=xsupplicant
 PKG_VERSION:=1.2.7
 PKG_RELEASE:=1
 PKG_NAME:=xsupplicant
 PKG_VERSION:=1.2.7
 PKG_RELEASE:=1
-PKG_MD5SUM:=f66c49cd6e4f331d05bf83513ed91990
 
 
-PKG_SOURCE_URL:=@SF/open1x
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=@SF/open1x
+PKG_MD5SUM:=f66c49cd6e4f331d05bf83513ed91990
 PKG_CAT:=zcat
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
 PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
 
 PKG_CAT:=zcat
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
 PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
 
+PKG_BUILDDEP:=madwifi
+
 include $(INCLUDE_DIR)/package.mk
 
 define Package/xsupplicant
 include $(INCLUDE_DIR)/package.mk
 
 define Package/xsupplicant
@@ -27,8 +29,9 @@ define Package/xsupplicant
   CATEGORY:=Network
   DEPENDS:=+libopenssl +wireless-tools
   TITLE:=A fully compliant 802.1x authenticator
   CATEGORY:=Network
   DEPENDS:=+libopenssl +wireless-tools
   TITLE:=A fully compliant 802.1x authenticator
-  DESCRIPTION:=This software allows a GNU/Linux or BSD workstation to authenticate with\\\
-       a RADIUS server using 802.1x and various EAP protocols.\\\
+  DESCRIPTION:=\
+       This software allows a GNU/Linux or BSD workstation to authenticate with \\\
+       a RADIUS server using 802.1x and various EAP protocols.
   URL:=http://open1x.sourceforge.net/
 endef
 
   URL:=http://open1x.sourceforge.net/
 endef
 
@@ -37,58 +40,32 @@ define Package/xsupplicant/conffiles
 endef
 
 define Build/Configure 
 endef
 
 define Build/Configure 
-       (cd $(PKG_BUILD_DIR); rm -rf config.{cache,status}; \
-               touch configure.in; \
-               touch aclocal.m4; \
-               touch Makefile.in; \
-               touch configure; \
-               $(TARGET_CONFIGURE_OPTS) \
-               CFLAGS="$(TARGET_CFLAGS)" \
-               CPPFLAGS="-I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/include \
-                       -I$(PKG_BUILD_DIR)/lib/libxsupconfig/ \
-                       -I$(STAGING_DIR)/usr/include/madwifi" \
-               LDFLAGS="-L$(STAGING_DIR)/usr/lib -L$(STAGING_DIR)/lib" \
-               CC="$(TARGET_CROSS)gcc" \
-               ./configure \
-                       --target=$(GNU_TARGET_NAME) \
-                       --host=$(GNU_TARGET_NAME) \
-                       --build=$(GNU_HOST_NAME) \
-                       --program-prefix="" \
-                       --program-suffix="" \
-                       --prefix=/usr \
-                       --exec-prefix=/usr \
-                       --bindir=/usr/bin \
-                       --datadir=/usr/share \
-                       --includedir=/usr/include \
-                       --infodir=/usr/share/info \
-                       --libdir=/usr/lib \
-                       --libexecdir=/usr/lib \
-                       --localstatedir=/var \
-                       --mandir=/usr/share/man \
-                       --sbindir=/usr/sbin \
-                       --sysconfdir=/etc \
-                       $(DISABLE_LARGEFILE) \
-                       $(DISABLE_NLS) \
-                       --with-openssl="$(STAGING_DIR)/usr" \
-                       --with-madwifi-path="$(STAGING_DIR)/usr/include/madwifi" \
+       (cd $(PKG_BUILD_DIR); touch \
+               configure.in \
+               aclocal.m4 \
+               Makefile.in \
+               configure \
        );
        );
+       $(call Build/Configure/Default, \
+               --with-openssl="$(STAGING_DIR)/usr" \
+               --with-madwifi-path="$(STAGING_DIR)/usr/include/madwifi" \
+               , \
+               CPPFLAGS="$$$$CPPFLAGS -I$(STAGING_DIR)/usr/include/madwifi" \
+       )
 endef
 
 define Build/Compile   
 endef
 
 define Build/Compile   
-       rm -rf $(PKG_INSTALL_DIR)
-       mkdir -p $(PKG_INSTALL_DIR)
        $(MAKE) -C $(PKG_BUILD_DIR) \
        $(MAKE) -C $(PKG_BUILD_DIR) \
-               CC="$(TARGET_CC)" \
-               DESTDIR=$(PKG_INSTALL_DIR) \
+               DESTDIR="$(PKG_INSTALL_DIR)" \
                all install
 endef
 
 define Package/xsupplicant/install     
                all install
 endef
 
 define Package/xsupplicant/install     
-       install -d -m0755 $(1)/etc
-       install -m0644 $(PKG_BUILD_DIR)/etc/xsupplicant.conf $(1)/etc/
-       install -d -m0755 $(1)/usr/bin
+       $(INSTALL_DIR) $(1)/etc
+       $(INSTALL_DATA) $(PKG_BUILD_DIR)/etc/xsupplicant.conf $(1)/etc/
+       $(INSTALL_DIR) $(1)/usr/bin
        $(CP) $(PKG_INSTALL_DIR)/usr/bin/xsup_* $(1)/usr/bin/
        $(CP) $(PKG_INSTALL_DIR)/usr/bin/xsup_* $(1)/usr/bin/
-       install -d -m0755 $(1)/usr/sbin
+       $(INSTALL_DIR) $(1)/usr/sbin
        $(CP) $(PKG_INSTALL_DIR)/usr/sbin/xsupplicant $(1)/usr/sbin/
 endef
 
        $(CP) $(PKG_INSTALL_DIR)/usr/sbin/xsupplicant $(1)/usr/sbin/
 endef