xsupplicant: fix compile errors related to iwlib.h
[openwrt/svn-archive/archive.git] / net / xsupplicant / Makefile
index f5e11efc33e54fcd9c86a8ca96bf502202a56622..ec56621a523c5f4401d1d23aa58ebdfec578fc91 100644 (file)
@@ -1,58 +1,58 @@
 #
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2009 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=xsupplicant
 PKG_VERSION:=1.2.8
-PKG_RELEASE:=1
+PKG_RELEASE:=3
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@SF/open1x
 PKG_MD5SUM:=75f89731b905eb8d36a52621661e1226
 
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
-
-PKG_BUILD_DEPENDS:=madwifi
+PKG_BUILD_DEPENDS:=PACKAGE_kmod-madwifi:madwifi
 
 include $(INCLUDE_DIR)/package.mk
 
 define Package/xsupplicant
   SECTION:=net
   CATEGORY:=Network
-  DEPENDS:=+libopenssl +wireless-tools
+  DEPENDS:=+libopenssl +libiw
   TITLE:=A fully compliant 802.1x authenticator
   URL:=http://open1x.sourceforge.net/
 endef
 
 define Package/xsupplicant/description
      This software allows a GNU/Linux or BSD workstation to authenticate with 
      a RADIUS server using 802.1x and various EAP protocols.
+ This software allows a GNU/Linux or BSD workstation to authenticate with 
+ a RADIUS server using 802.1x and various EAP protocols.
 endef
 
 define Package/xsupplicant/conffiles
 /etc/xsupplicant.conf
 endef
 
-define Build/Configure 
+TARGET_CFLAGS += --std=gnu99
+
+CONFIGURE_ARGS+= \
+       --with-openssl="$(STAGING_DIR)/usr" \
+       --with-madwifi-path="$(STAGING_DIR)/usr/include/madwifi" \
+
+CONFIGURE_VARS+= \
+       CPPFLAGS="$$$$CPPFLAGS -I$(STAGING_DIR)/usr/include/madwifi" \
+
+define Build/Prepare
+       $(call Build/Prepare/Default)
        (cd $(PKG_BUILD_DIR); touch \
                configure.in \
                aclocal.m4 \
                Makefile.in \
                configure \
        );
-       $(call Build/Configure/Default, \
-               --with-openssl="$(STAGING_DIR)/usr" \
-               --with-madwifi-path="$(STAGING_DIR)/usr/include/madwifi" \
-               , \
-               CPPFLAGS="$$$$CPPFLAGS -I$(STAGING_DIR)/usr/include/madwifi" \
-       )
 endef
 
 define Build/Compile