[package] update xtables-addons to 1.7 (#5369)
[openwrt/svn-archive/archive.git] / net / xtables-addons / Makefile
index e8dab43c44243a30795f3e357525f4764acd331c..e4412a840974e5ee32570524fd266ef08bea2f1e 100644 (file)
@@ -4,19 +4,17 @@
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/kernel.mk
 
 PKG_NAME:=xtables-addons
-PKG_VERSION:=1.9
+PKG_VERSION:=1.17
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
-PKG_SOURCE_URL:=http://dev.medozas.de/files/xtables/
-PKG_MD5SUM:=578176c969a70858bfc06d9ee3b5dbda
-
+PKG_MD5SUM:=eca2e3f4f4904814e3a301539876fae6
+PKG_SOURCE_URL:=@SF/xtables-addons
 PKG_BUILD_DEPENDS:=iptables
 
 include $(INCLUDE_DIR)/package.mk
@@ -36,11 +34,12 @@ CONFIGURE_ARGS+= \
        --with-xtables="$(STAGING_DIR)/usr" \
        --with-xtlibdir="/usr/lib/iptables" \
 
-define Build/Compile   
+define Build/Compile
        $(MAKE) -C $(PKG_BUILD_DIR) \
                ARCH="$(LINUX_KARCH)" \
                CROSS_COMPILE="$(TARGET_CROSS)" \
                DESTDIR="$(PKG_INSTALL_DIR)" \
+               DEPMOD="/bin/true" \
                all install
 endef
 
@@ -93,5 +92,5 @@ $(eval $(call KernelPackage,compat-xtables))
 $(eval $(call BuildTemplate,chaos,CHAOS,xt_CHAOS,47,+kmod-compat-xtables +kmod-ipt-delude +kmod-ipt-tarpit))
 $(eval $(call BuildTemplate,condition,condition,xt_condition,46))
 $(eval $(call BuildTemplate,delude,DELUDE,xt_DELUDE,46,+kmod-compat-xtables))
-$(eval $(call BuildTemplate,portscan,portscan,xt_portscan,46))
 $(eval $(call BuildTemplate,tarpit,TARPIT,xt_TARPIT,46,+kmod-compat-xtables))
+$(eval $(call BuildTemplate,ipp2p,ipp2p,xt_ipp2p,46))