[packages] xtables-addons: remove ipset, now in trunk after [18833]
[openwrt/svn-archive/archive.git] / net / xtables-addons / Makefile
index 45ac5d99ee1338d8d17af6056e959fe3304fc250..eec557bf30d2308ab17d40f9dded6edeed155be2 100644 (file)
@@ -9,27 +9,23 @@ include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/kernel.mk
 
 PKG_NAME:=xtables-addons
-PKG_VERSION:=1.9
+PKG_VERSION:=1.18
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
-PKG_MD5SUM:=578176c969a70858bfc06d9ee3b5dbda
-PKG_SOURCE_URL:= \
-       http://dev.medozas.de/files/xtables/ \
-       http://dev.medozas.de/files/xtables/old
-
+PKG_MD5SUM:=5a8d2edbf5a3470bba58d6a60c350805
+PKG_SOURCE_URL:=@SF/xtables-addons
 PKG_BUILD_DEPENDS:=iptables
 
 include $(INCLUDE_DIR)/package.mk
 
 define Package/xtables-addons
   SECTION:=net
-  CATEGORY:=Base system
+  CATEGORY:=Network
   TITLE:=Extensions not distributed in the main Xtables
-  URL:=http://jengelh.medozas.de/projects/xtables/
+  URL:=http://xtables-addons.sourceforge.net/
 endef
 
-
 # uses GNU configure
 
 CONFIGURE_ARGS+= \
@@ -42,20 +38,24 @@ define Build/Compile
                ARCH="$(LINUX_KARCH)" \
                CROSS_COMPILE="$(TARGET_CROSS)" \
                DESTDIR="$(PKG_INSTALL_DIR)" \
+               DEPMOD="/bin/true" \
                all install
 endef
 
 # 1: extension/module suffix used in package name
 # 2: extension/module display name used in package title/description
-# 3: list of extensions/modules to package
-# 4: module load priority
-# 5: module depends
+# 3: list of extensions to package
+# 4: list of modules to package
+# 5: module load priority
+# 6: module depends
 define BuildTemplate
 
+ ifneq ($(3),)
   define Package/iptables-mod-$(1)
     $$(call Package/xtables-addons)
+    CATEGORY:=Network
     TITLE:=$(2) iptables extension
-    DEPENDS:=iptables +kmod-ipt-$(1)
+    DEPENDS:= @LINUX_2_6 iptables $(if $(4),+kmod-ipt-$(1))
   endef
 
   define Package/iptables-mod-$(1)/install
@@ -68,32 +68,26 @@ define BuildTemplate
   endef
 
   $$(eval $$(call BuildPackage,iptables-mod-$(1)))
+ endif
 
+ ifneq ($(4),)
   define KernelPackage/ipt-$(1)
     SUBMENU:=Netfilter Extensions
     TITLE:=$(2) netfilter module
-    DEPENDS:=@LINUX_2_6 kmod-ipt-core $(5)
-    FILES:=$(PKG_BUILD_DIR)/extensions/$(3).$(LINUX_KMOD_SUFFIX)
-    AUTOLOAD:=$(call AutoLoad,$(4),$(3))
+    DEPENDS:= @LINUX_2_6 kmod-ipt-core $(6)
+    FILES:=$(foreach mod,$(4),$(PKG_BUILD_DIR)/extensions/$(mod).$(LINUX_KMOD_SUFFIX))
+    AUTOLOAD:=$(call AutoLoad,$(5),$(notdir $(4)))
   endef
 
   $$(eval $$(call KernelPackage,ipt-$(1)))
+ endif
 
 endef
 
-define KernelPackage/compat-xtables
-  SUBMENU:=Netfilter Extensions
-  TITLE:=API compatibilty layer module
-  DEPENDS:=@LINUX_2_6
-  FILES:=$(PKG_BUILD_DIR)/extensions/compat_xtables.$(LINUX_KMOD_SUFFIX)
-  AUTOLOAD:=$(call AutoLoad,45,compat_xtables)
-endef
-
-$(eval $(call KernelPackage,compat-xtables))
-
-$(eval $(call BuildTemplate,chaos,CHAOS,xt_CHAOS,47,+kmod-compat-xtables +kmod-ipt-delude +kmod-ipt-tarpit))
-$(eval $(call BuildTemplate,condition,condition,xt_condition,46))
-$(eval $(call BuildTemplate,delude,DELUDE,xt_DELUDE,46,+kmod-compat-xtables))
-$(eval $(call BuildTemplate,portscan,portscan,xt_portscan,46))
-$(eval $(call BuildTemplate,tarpit,TARPIT,xt_TARPIT,46,+kmod-compat-xtables))
-$(eval $(call BuildTemplate,ipp2p,ipp2p,xt_ipp2p,46))
+#$(eval $(call BuildTemplate,SUFFIX,DESCRIPTION,EXTENSION,MODULE,PRIORITY,DEPENDS))
+$(eval $(call BuildTemplate,compat-xtables,API compatibilty layer,,compat_xtables,45,))
+$(eval $(call BuildTemplate,chaos,CHAOS,xt_CHAOS,xt_CHAOS,47,+kmod-ipt-compat-xtables +kmod-ipt-delude +kmod-ipt-tarpit))
+$(eval $(call BuildTemplate,condition,Condition,xt_condition,xt_condition,46,))
+$(eval $(call BuildTemplate,delude,DELUDE,xt_DELUDE,xt_DELUDE,46,+kmod-ipt-compat-xtables))
+$(eval $(call BuildTemplate,tarpit,TARPIT,xt_TARPIT,xt_TARPIT,46,+kmod-ipt-compat-xtables))
+$(eval $(call BuildTemplate,ipp2p,IPP2P,xt_ipp2p,xt_ipp2p,46,))