[packages] xtables-addons: remove ipset, now in trunk after [18833]
[openwrt/svn-archive/archive.git] / net / xtables-addons / Makefile
index a47a06dc05cc6fe21c85ac0293e9889f236480a3..eec557bf30d2308ab17d40f9dded6edeed155be2 100644 (file)
@@ -9,11 +9,11 @@ include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/kernel.mk
 
 PKG_NAME:=xtables-addons
-PKG_VERSION:=1.17
+PKG_VERSION:=1.18
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
-PKG_MD5SUM:=eca2e3f4f4904814e3a301539876fae6
+PKG_MD5SUM:=5a8d2edbf5a3470bba58d6a60c350805
 PKG_SOURCE_URL:=@SF/xtables-addons
 PKG_BUILD_DEPENDS:=iptables
 
@@ -23,13 +23,7 @@ define Package/xtables-addons
   SECTION:=net
   CATEGORY:=Network
   TITLE:=Extensions not distributed in the main Xtables
-  URL:=http://jengelh.medozas.de/projects/xtables/
-endef
-
-define Package/ipset
-$(call Package/xtables-addons)
-  TITLE:=IPset administration utility
-  DEPENDS:= @LINUX_2_6 +iptables-mod-ipset
+  URL:=http://xtables-addons.sourceforge.net/
 endef
 
 # uses GNU configure
@@ -39,31 +33,6 @@ CONFIGURE_ARGS+= \
        --with-xtables="$(STAGING_DIR)/usr" \
        --with-xtlibdir="/usr/lib/iptables" \
 
-IPSET_EXT:= \
-       ipset_iphash \
-       ipset_ipmap \
-       ipset_ipporthash \
-       ipset_ipportnethash \
-       ipset_iptree \
-       ipset_iptreemap \
-       ipset_macipmap \
-       ipset_nethash \
-       ipset_portmap \
-       ipset_setlist \
-
-IPSET_MOD:= \
-       ipset/ip_set \
-       ipset/ip_set_iphash \
-       ipset/ip_set_ipmap \
-       ipset/ip_set_ipporthash \
-       ipset/ip_set_iptree \
-       ipset/ip_set_iptreemap \
-       ipset/ip_set_macipmap \
-       ipset/ip_set_nethash \
-       ipset/ip_set_portmap \
-       ipset/ipt_set \
-       ipset/ipt_SET \
-
 define Build/Compile
        $(MAKE) -C $(PKG_BUILD_DIR) \
                ARCH="$(LINUX_KARCH)" \
@@ -84,7 +53,7 @@ define BuildTemplate
  ifneq ($(3),)
   define Package/iptables-mod-$(1)
     $$(call Package/xtables-addons)
-    CATEGORY:=Base system
+    CATEGORY:=Network
     TITLE:=$(2) iptables extension
     DEPENDS:= @LINUX_2_6 iptables $(if $(4),+kmod-ipt-$(1))
   endef
@@ -115,13 +84,6 @@ define BuildTemplate
 
 endef
 
-define Package/ipset/install
-       $(INSTALL_DIR) $(1)/usr/sbin
-       $(CP) $(PKG_INSTALL_DIR)/usr/sbin/ipset $(1)/usr/sbin/
-endef
-
-$(eval $(call BuildPackage,ipset))
-
 #$(eval $(call BuildTemplate,SUFFIX,DESCRIPTION,EXTENSION,MODULE,PRIORITY,DEPENDS))
 $(eval $(call BuildTemplate,compat-xtables,API compatibilty layer,,compat_xtables,45,))
 $(eval $(call BuildTemplate,chaos,CHAOS,xt_CHAOS,xt_CHAOS,47,+kmod-ipt-compat-xtables +kmod-ipt-delude +kmod-ipt-tarpit))
@@ -129,4 +91,3 @@ $(eval $(call BuildTemplate,condition,Condition,xt_condition,xt_condition,46,))
 $(eval $(call BuildTemplate,delude,DELUDE,xt_DELUDE,xt_DELUDE,46,+kmod-ipt-compat-xtables))
 $(eval $(call BuildTemplate,tarpit,TARPIT,xt_TARPIT,xt_TARPIT,46,+kmod-ipt-compat-xtables))
 $(eval $(call BuildTemplate,ipp2p,IPP2P,xt_ipp2p,xt_ipp2p,46,))
-$(eval $(call BuildTemplate,ipset,IPset,$(IPSET_EXT),$(IPSET_MOD),46,))