[PATCH] yaddns: update to 1.1-rc2
[openwrt/svn-archive/archive.git] / net / yaddns / Makefile
index c90c9e3f5fb73f26eead0fa989df7f2827f8750a..8f55694ffce859a6c1fa75e10a40e30dfc53ffe5 100644 (file)
@@ -8,12 +8,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=yaddns
-PKG_VERSION:=0.1.1
+PKG_VERSION:=1.1-rc2
 PKG_RELEASE:=1
 
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
-PKG_SOURCE_URL:=@SF/yaddns
-PKG_MD5SUM:=2708d3e47a486b1872ef9c5537cd2f0d
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=http://download.gna.org/yaddns/
+PKG_MD5SUM:=919a25bd66abf926e049f3afea619e19
 
 PKG_INSTALL:=1
 
@@ -22,7 +22,7 @@ include $(INCLUDE_DIR)/package.mk
 define Package/yaddns
   SECTION:=net
   CATEGORY:=Network
-  DEPENDS:=
+  SUBMENU:=IP Addresses and Names
   TITLE:=Yet Another DDNS client
   URL:=http://patatrac.info/yaddns
 endef
@@ -32,9 +32,14 @@ Yaddns is a small ddns client with multiple ddns server supports (dyndns, ...)
 and a high flexibility. Yaddns is particularly appropriate for embedded systems.
 endef
 
+define Package/yaddns/conffiles
+/etc/config/ddns
+endef
+
 define Package/yaddns/install
        $(INSTALL_DIR) $(1)/usr/bin
        $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/yaddns $(1)/usr/bin/
+       $(CP) ./files/* $(1)/
 endef
 
 $(eval $(call BuildPackage,yaddns))