[net] File Transfer: Moved old FTP category and combined with other file transfer...
[openwrt/svn-archive/archive.git] / net / yafc / Makefile
index 92cc5aed8a8fdf46b9c4479d83e1b5795a5a655a..7ea0e94e7455bcdba206908557340d368229d034 100644 (file)
@@ -1,43 +1,45 @@
-# 
-# Copyright (C) 2006 OpenWrt.org
+#
+# Copyright (C) 2008-2010 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id: Makefile 4112 2006-07-02 20:33:21Z nico $
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=yafc
 PKG_VERSION:=1.1.1
-PKG_RELEASE:=1
-PKG_MD5SUM:=832d074183a36ee15b47553ed5962fce
+PKG_RELEASE:=2
 
-PKG_SOURCE_URL:=@SF/$(PKG_NAME)
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
-PKG_CAT:=bzcat
+PKG_SOURCE_URL:=@SF/$(PKG_NAME)
+PKG_MD5SUM:=832d074183a36ee15b47553ed5962fce
 
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+PKG_FIXUP:=libtool
+PKG_REMOVE_FILES:=autogen.sh aclocal.m4
 
 include $(INCLUDE_DIR)/package.mk
 
 define Package/yafc
+  SUBMENU:=File Transfer
   SECTION:=net
   CATEGORY:=Network
-  DEPENDS:=+libpcap
+  DEPENDS:=+libncurses +libreadline
   TITLE:=Yafc is yet another ftp client.
-  DESCRIPTION:=console-based FTP client
-  URL:=http://yacf.sourceforge.net
+  URL:=http://yafc.sourceforge.net/
 endef
 
-define Build/Configure
-$(call Build/Configure/Default,--includedir=$(PKG_BUILD_DIR)/)
+# uses GNU configure
+CONFIGURE_VARS += \
+       bash_cv_func_sigsetjmp=missing
+
+define Build/Compile
+       $(MAKE) -C $(PKG_BUILD_DIR)
 endef
 
 define Package/yafc/install
-       install -m0755 -d $(1)/usr/sbin
-       $(CP) $(PKG_BUILD_DIR)/src/$(PKG_NAME) $(1)/usr/sbin/
+       $(INSTALL_DIR) $(1)/usr/sbin
+       $(CP) $(PKG_BUILD_DIR)/src/yafc $(1)/usr/sbin/
 endef
 
 $(eval $(call BuildPackage,yafc))