Remove krb5 patches made unnecessary by version bump
[openwrt/svn-archive/archive.git] / net / znc / Makefile
index 1c1c7fa3c3d1a50e93e84bbe497e12a4c98ffe75..3f38c22216953d9720f6e59f9be27b149b06594c 100644 (file)
@@ -1,60 +1,65 @@
 #
-# Copyright (C) 2009 OpenWrt.org
+# Copyright (C) 2009-2010 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
+
 include $(TOPDIR)/rules.mk
+
 PKG_NAME:=znc
-PKG_VERSION:=0.068
-PKG_RELEASE:=1
+PKG_VERSION:=0.078
+PKG_RELEASE:=2
+
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=http://kent.dl.sourceforge.net/sourceforge/znc
-PKG_MD5SUM:=763162d90c67814780de67aa88347c38
+PKG_SOURCE_URL:=@SF/znc
+PKG_MD5SUM:=b1379bd6609353ebbc8df7ec19bd004f
+
 include $(INCLUDE_DIR)/package.mk
+
 define Package/znc
   SUBMENU:=Instant Messaging
   SECTION:=net
   CATEGORY:=Network
-  DEPENDS:=+openssl +uclibcxx
+  DEPENDS:=+libopenssl +uclibcxx
   TITLE:=ZNC
   URL:=http://en.znc.in/
 endef
+
 define Package/znc/description
-       ZNC is an IRC bouncer with many advanced features like detaching, multiple users, per channel playback buffer, SSL, IPv6, transparent DCC bouncing, and c++ module 
-       support to name a few.
+       ZNC is an IRC bouncer with many advanced features like detaching,
+       multiple users, per channel playback buffer, SSL, IPv6, transparent DCC
+       bouncing, and c++ module support to name a few.
 endef
+
 CONFIGURE_VARS += \
-       CXX="$(TARGET_CROSS)-g++"
+       CXX="$(TARGET_CROSS)-g++-uc"
        CXXFLAGS="$(TARGET_CFLAGS) -fno-builtin -fno-rtti -nostdinc++" \
        CPPFLAGS="-I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/include" \
-       LDFLAGS="-nodefaultlibs -L$(STAGING_DIR)/usr/lib -L$(STAGING_DIR)/lib"
-       LIBS="-luClibc++ -lc -lm -lgcc -lssl"
+       LDFLAGS="-nodefaultlibs -L$(STAGING_DIR)/usr/lib -L$(STAGING_DIR)/lib" \
+       LIBS="-luClibc++ -lm -lssl $(LIBGCC_S) -lc"
 
 CONFIGURE_ARGS += \
        $(TARGET_CONFIGURE_OPTS) \
-       --disable-perl \
-       --disable-ipv6 \
+       --disable-c-ares \
+       --disable-modules \
+       --disable-perl
+
+MAKE_FLAGS += \
+       CXX="g++-uc"
 
 define Build/Configure
        $(call Build/Configure/Default,)
        $(call libtool_disable_rpath)
 endef
+
 define Build/Compile
        $(call Build/Compile/Default,)
 endef
+
 define Package/znc/install
        $(INSTALL_DIR) $(1)/usr/bin
        $(INSTALL_BIN) $(PKG_BUILD_DIR)/znc $(1)/usr/bin/
 endef
+
 $(eval $(call BuildPackage,znc))