fix BR2_ and CONFIG_ issues
[openwrt/svn-archive/archive.git] / openwrt / Makefile
index 04a07ddbf61aaf147c9493f90a44c0f0630123a7..06288de6b86b1d1ab061080b8f4d5e6177d8e3e6 100644 (file)
@@ -1,7 +1,6 @@
-# Makefile for OpenWRT
+# Makefile for OpenWrt
 #
-# Copyright (C) 2005 by Felix Fietkau <nbd@vd-s.ath.cx>
-# Copyright (C) 1999-2004 by Erik Andersen <andersen@codepoet.org>
+# Copyright (C) 2006 by Felix Fietkau <openwrt@nbd.name>
 #
 # This program is free software; you can redistribute it and/or modify
 # it under the terms of the GNU General Public License as published by
 # Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
 #
 
+RELEASE:=Kamikaze
+#VERSION:=2.0 # uncomment for final release
+
 #--------------------------------------------------------------
 # Just run 'make menuconfig', configure stuff, then run 'make'.
 # You shouldn't need to mess with anything beyond this point...
 #--------------------------------------------------------------
 TOPDIR=${shell pwd}
 export TOPDIR
-CONFIG_CONFIG_IN = Config.in
-CONFIG_DEFCONFIG = .defconfig
-CONFIG = package/config
-
-noconfig_targets := menuconfig config oldconfig randconfig \
-       defconfig allyesconfig allnoconfig release tags
 
-# Pull in the user's configuration file
-ifeq ($(filter $(noconfig_targets),$(MAKECMDGOALS)),)
--include $(TOPDIR)/.config
+OPENWRTVERSION:=$(RELEASE)
+ifneq ($(VERSION),)
+OPENWRTVERSION:=$(VERSION) ($(OPENWRTVERSION))
+else
+REV:=$(shell LANG=C svn info | awk '/^Revision:/ { print$$2 }' )
+ifneq ($(REV),)
+OPENWRTVERSION:=$(OPENWRTVERSION)/r$(REV)
 endif
+endif
+export OPENWRTVERSION
 
-ifeq ($(strip $(BR2_HAVE_DOT_CONFIG)),y)
-include $(TOPDIR)/rules.mk
-
-all: world
-
-##############################################################
-#
-# Build the toolchain
-#
-##############################################################
-toolchain_install:
-       $(MAKE) -C toolchain install
-
-##############################################################
-#
-# Make all packages
-#
-##############################################################
-
-package_install: toolchain
-       $(MAKE) -C package compile install
-
-#############################################################
-#
-# You should probably leave this stuff alone unless you know
-# what you are doing.
-#
-#############################################################
-
-
-# In this section, we need .config
-include .config.cmd
-
-world: $(DL_DIR) $(BUILD_DIR) target_prepare $(TARGET_DIR) toolchain_install package_install target_install package_index
-
-.PHONY: all world clean dirclean distclean image_clean target_clean source target_prepare target_install toolchain_install package_install
-
-package_index:
-       (cd $(PACKAGE_DIR); \
-               $(STAGING_DIR)/usr/bin/ipkg-make-index . > Packages \
-       )
-
-target_prepare:
-       $(MAKE) -C target prepare
-
-target_install:
-       $(MAKE) -C target install
-
-$(DL_DIR):
-       @mkdir -p $(DL_DIR)
-
-$(BUILD_DIR):
-       @mkdir -p $(BUILD_DIR)
-
-source: $(TARGETS_SOURCE)
-
-#############################################################
-#
-# Cleanup and misc junk
-#
-#############################################################
-image_clean:
-       rm -f $(STAMP_DIR)/.*-compile
-       rm -f $(STAMP_DIR)/.*-install
-       rm -rf $(BIN_DIR)
-       
-target_clean: image_clean
-       rm -rf $(TARGET_DIR)
-
-clean: target_clean
-       @$(MAKE) -C $(CONFIG) clean
-
-dirclean: clean
-       rm -rf $(STAMP_DIR)
-       $(MAKE) -C package clean
-       $(MAKE) -C target clean
-       rm -rf $(BUILD_DIR)
-
-distclean: clean
-       rm -rf $(STAMP_DIR) $(DL_DIR) $(BUILD_DIR) $(TOOL_BUILD_DIR)
-       rm -f .config* .tmpconfig.h
-
-sourceball: distclean
-       set -e; \
-       cd ..; \
-       rm -f buildroot.tar.bz2; \
-       tar -cvf buildroot.tar buildroot; \
-       bzip2 -9 buildroot.tar; \
-
-else # ifeq ($(strip $(BR2_HAVE_DOT_CONFIG)),y)
-
-all: menuconfig
-
-# configuration
-# ---------------------------------------------------------------------------
-
-$(CONFIG)/conf:
-       $(MAKE) -C $(CONFIG) conf
-       -@if [ ! -f .config ] ; then \
-               cp $(CONFIG_DEFCONFIG) .config; \
-       fi
-$(CONFIG)/mconf:
-       $(MAKE) -C $(CONFIG) 
-       -@if [ ! -f .config ] ; then \
-               cp $(CONFIG_DEFCONFIG) .config; \
-       fi
-
-menuconfig: $(CONFIG)/mconf
-       -touch .config
-       -cp .config .config.test
-       @$(CONFIG)/mconf $(CONFIG_CONFIG_IN)
-       -./scripts/configtest.pl
+all:
 
-config: $(CONFIG)/conf
-       -touch .config
-       -cp .config .config.test
-       @$(CONFIG)/conf $(CONFIG_CONFIG_IN)
-       -./scripts/configtest.pl
+.pkginfo: FORCE
+ifeq ($(shell ./scripts/timestamp.pl -p .pkginfo package),package)
+       @echo Collecting package info...
+       @-for makefile in package/*/Makefile; do \
+               echo Source-Makefile: $$makefile; \
+               $(MAKE) DUMP=1 -f $$makefile 2>&- || true; \
+       done > $@
+endif
 
-oldconfig: $(CONFIG)/conf
-       -touch .config
-       -cp .config .config.test
-       @$(CONFIG)/conf -o $(CONFIG_CONFIG_IN)
-       -./scripts/configtest.pl
+.config.in: .pkginfo
+       ./scripts/gen_menuconfig.pl < $< > $@ || rm -f $@
 
-randconfig: $(CONFIG)/conf
-       -touch .config
-       -cp .config .config.test
-       @$(CONFIG)/conf -r $(CONFIG_CONFIG_IN)
-       -./scripts/configtest.pl
+pkginfo-clean: FORCE
+       -rm -f .pkginfo .config.in
 
-allyesconfig: $(CONFIG)/conf
-       #@$(CONFIG)/conf -y $(CONFIG_CONFIG_IN)
-       #sed -i -e "s/^CONFIG_DEBUG.*/# CONFIG_DEBUG is not set/" .config
-       -touch .config
-       -cp .config .config.test
-       @$(CONFIG)/conf -o $(CONFIG_CONFIG_IN)
-       -./scripts/configtest.pl
+scripts/config/mconf: .config.in
+       $(MAKE) -C scripts/config all
 
-allnoconfig: $(CONFIG)/conf
-       -touch .config
-       -cp .config .config.test
-       @$(CONFIG)/conf -n $(CONFIG_CONFIG_IN)
-       -./scripts/configtest.pl
+scripts/config/conf: .config.in
+       $(MAKE) -C scripts/config conf
 
-defconfig: $(CONFIG)/conf
-       -touch .config
-       -cp .config .config.test
-       @$(CONFIG)/conf -d $(CONFIG_CONFIG_IN)
-       -./scripts/configtest.pl
+menuconfig: scripts/config/mconf
+       $< Config.in
 
-endif # ifeq ($(strip $(BR2_HAVE_DOT_CONFIG)),y)
+config: scripts/config/conf
+       $< Config.in
 
-.PHONY: dummy subdirs release distclean clean config oldconfig \
-       menuconfig tags check test depend
+config-clean:
+       $(MAKE) -C scripts/config clean
 
+.PHONY: FORCE
+FORCE: