fix the xt/ipt module path issue
[openwrt/svn-archive/archive.git] / openwrt / Makefile
index b8c9b10b7068b644538aeaa550fa85cbe49f4e36..abc9dfee2756e6c2458618791d074f351ff5979d 100644 (file)
@@ -1,5 +1,6 @@
-# Makefile for buildroot2
+# Makefile for OpenWrt
 #
+# Copyright (C) 2005 by Felix Fietkau <openwrt@nbd.name>
 # Copyright (C) 1999-2004 by Erik Andersen <andersen@codepoet.org>
 #
 # This program is free software; you can redistribute it and/or modify
 # Just run 'make menuconfig', configure stuff, then run 'make'.
 # You shouldn't need to mess with anything beyond this point...
 #--------------------------------------------------------------
-TOPDIR=./
+TOPDIR=${shell pwd}
+export TOPDIR
+
+ifneq ($(DEVELOPER),)
+CONFIG_CONFIG_IN = Config.in.devel
+else
 CONFIG_CONFIG_IN = Config.in
+endif
 CONFIG_DEFCONFIG = .defconfig
 CONFIG = package/config
 
@@ -31,28 +38,15 @@ noconfig_targets := menuconfig config oldconfig randconfig \
 
 # Pull in the user's configuration file
 ifeq ($(filter $(noconfig_targets),$(MAKECMDGOALS)),)
--include $(TOPDIR).config
-endif
-
-ifeq ($(BR2_TAR_VERBOSITY),y)
-TAR_OPTIONS=-xvf
-else
-TAR_OPTIONS=-xf
+-include $(TOPDIR)/.config
 endif
 
 ifeq ($(strip $(BR2_HAVE_DOT_CONFIG)),y)
+include $(TOPDIR)/rules.mk
 
-#############################################################
-#
-# The list of stuff to build for the target toolchain
-# along with the packages to build for the target.
-#
-##############################################################
-TARGETS:=host-sed kernel-headers uclibc-configured binutils gcc uclibc-target-utils
-TARGETS+=openwrt-sstrip linux
+all: world
 
-include toolchain/Makefile.in
-include package/Makefile.in
+.NOTPARALLEL:
 
 #############################################################
 #
@@ -61,93 +55,66 @@ include package/Makefile.in
 #
 #############################################################
 
-
-
-all:   world
-
 # In this section, we need .config
 include .config.cmd
 
-# We also need the various per-package makefiles, which also add
-# each selected package to TARGETS if that package was selected
-# in the .config file.
-include toolchain/*/*.mk
-include package/*/*.mk
-include target/*/*.mk
+world: $(DL_DIR) $(BUILD_DIR) configtest 
+       $(MAKE) toolchain/install target/compile package/compile root_clean package/install target/install package_index
+       @$(TRACE) Build complete.
 
-# target stuff is last so it can override anything else
-include target/Makefile.in
+.PHONY: all world clean dirclean distclean image_clean target_clean source configtest
 
-TARGETS_CLEAN:=$(patsubst %,%-clean,$(TARGETS))
-TARGETS_SOURCE:=$(patsubst %,%-source,$(TARGETS))
-TARGETS_DIRCLEAN:=$(patsubst %,%-dirclean,$(TARGETS))
-
-world: $(DL_DIR) $(BUILD_DIR) $(STAGING_DIR) $(TARGET_DIR) $(TARGETS)
+configtest:
+       -cp .config .config.test
+       -scripts/configtest.pl
 
-.PHONY: all world clean dirclean distclean source $(TARGETS) \
-       $(TARGETS_CLEAN) $(TARGETS_DIRCLEAN) $(TARGETS_SOURCE) \
-       $(DL_DIR) $(BUILD_DIR) $(TOOL_BUILD_DIR) $(STAGING_DIR)
+package_index:
+       (cd $(PACKAGE_DIR); $(STAGING_DIR)/usr/bin/ipkg-make-index . > Packages)
 
-#############################################################
-#
-# staging and target directories do NOT list these as
-# dependancies anywhere else
-#
-#############################################################
 $(DL_DIR):
        @mkdir -p $(DL_DIR)
 
 $(BUILD_DIR):
        @mkdir -p $(BUILD_DIR)
 
-$(TOOL_BUILD_DIR):
-       @mkdir -p $(TOOL_BUILD_DIR)
-
-$(STAGING_DIR):
-       @mkdir -p $(STAGING_DIR)/lib
-       @mkdir -p $(STAGING_DIR)/include
-       @mkdir -p $(STAGING_DIR)/$(REAL_GNU_TARGET_NAME)
-       @ln -sf ../lib $(STAGING_DIR)/$(REAL_GNU_TARGET_NAME)/lib
-
-$(TARGET_DIR):
-       if [ -f "$(TARGET_SKELETON)" ] ; then \
-               zcat $(TARGET_SKELETON) | tar -C $(BUILD_DIR) -xf -; \
-       fi;
-       if [ -d "$(TARGET_SKEL_DIR)" ] ; then \
-               cp -a $(TARGET_SKEL_DIR)/* $(TARGET_DIR)/; \
-       fi;
-       -find $(TARGET_DIR) -type d -name CVS | xargs rm -rf
-       -find $(TARGET_DIR) -type d -name .svn | xargs rm -rf
-       -ln -sf /tmp/resolv.conf $(TARGET_DIR)
-       -mkdir -p $(TARGET_DIR)/jffs
-
-source: $(TARGETS_SOURCE)
+source: toolchain/source package/source target/source
+
+package/%:
+       @$(TRACE) $@
+       $(MAKE) -C package $(patsubst package/%,%,$@)
+
+target/%:
+       @$(TRACE) $@
+       $(MAKE) -C target $(patsubst target/%,%,$@)
+
+toolchain/%:
+       @$(TRACE) $@
+       $(MAKE) -C toolchain $(patsubst toolchain/%,%,$@)
 
 #############################################################
 #
 # Cleanup and misc junk
 #
 #############################################################
-clean: 
-       rm -rf $(TARGET_DIR) $(IMAGE).*
-       $(MAKE) openwrt-image-clean
+root_clean:
+       @$(TRACE) root_clean
+       rm -rf $(BUILD_DIR)/linux-*/root $(BUILD_DIR)/root
 
-dirclean: $(TARGETS_DIRCLEAN)
-       rm -rf $(TARGET_DIR) $(IMAGE).*
-       $(MAKE) openwrt-image-dirclean
+target_clean: root_clean
+       rm -f $(STAMP_DIR)/.*-compile
+       rm -f $(STAMP_DIR)/.*-install
+       rm -rf $(BIN_DIR)
 
-distclean: clean
-       rm -rf $(DL_DIR) $(BUILD_DIR) $(TOOL_BUILD_DIR) 
-       rm .config* .tmpconfig.h
+clean: dirclean
 
-sourceball:
+dirclean:
+       @$(TRACE) dirclean
+       @$(MAKE) -C $(CONFIG) clean
        rm -rf $(BUILD_DIR)
-       set -e; \
-       cd ..; \
-       rm -f buildroot.tar.bz2; \
-       tar -cvf buildroot.tar buildroot; \
-       bzip2 -9 buildroot.tar; \
 
+distclean: dirclean
+       rm -rf $(STAMP_DIR) $(DL_DIR) $(TOOL_BUILD_DIR) $(STAGING_DIR)
+       rm -f .config* .tmpconfig.h
 
 else # ifeq ($(strip $(BR2_HAVE_DOT_CONFIG)),y)
 
@@ -162,7 +129,7 @@ $(CONFIG)/conf:
                cp $(CONFIG_DEFCONFIG) .config; \
        fi
 $(CONFIG)/mconf:
-       $(MAKE) -C $(CONFIG) ncurses conf mconf
+       $(MAKE) -C $(CONFIG) 
        -@if [ ! -f .config ] ; then \
                cp $(CONFIG_DEFCONFIG) .config; \
        fi
@@ -192,8 +159,6 @@ randconfig: $(CONFIG)/conf
        -./scripts/configtest.pl
 
 allyesconfig: $(CONFIG)/conf
-       #@$(CONFIG)/conf -y $(CONFIG_CONFIG_IN)
-       #sed -i -e "s/^CONFIG_DEBUG.*/# CONFIG_DEBUG is not set/" .config
        -touch .config
        -cp .config .config.test
        @$(CONFIG)/conf -o $(CONFIG_CONFIG_IN)
@@ -211,16 +176,6 @@ defconfig: $(CONFIG)/conf
        @$(CONFIG)/conf -d $(CONFIG_CONFIG_IN)
        -./scripts/configtest.pl
 
-#############################################################
-#
-# Cleanup and misc junk
-#
-#############################################################
-clean:
-       @$(MAKE) -C $(CONFIG) clean
-
-distclean: clean
-
 endif # ifeq ($(strip $(BR2_HAVE_DOT_CONFIG)),y)
 
 .PHONY: dummy subdirs release distclean clean config oldconfig \