update avahi to new upstream release (v0.6.1)
[openwrt/svn-archive/archive.git] / openwrt / package / avahi / Makefile
index b5f5b943cd27d17e9c116581ed47c26d79e4acfd..a082d54699ab32a4cc426f245cd4b5fa2c9f14a9 100644 (file)
@@ -3,9 +3,9 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=avahi
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=avahi
-PKG_VERSION:=0.1
+PKG_VERSION:=0.6.1
 PKG_RELEASE:=1
 PKG_RELEASE:=1
-PKG_MD5SUM:=1ccbbc46d2aedf0c864b94c58ea220e6
+PKG_MD5SUM:=330613902c59bd597f140a8254e9f4ec
 
 PKG_SOURCE_URL:=http://www.freedesktop.org/~lennart/
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 
 PKG_SOURCE_URL:=http://www.freedesktop.org/~lennart/
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
@@ -24,8 +24,8 @@ $(PKG_BUILD_DIR)/.configured:
        (cd $(PKG_BUILD_DIR); rm -rf config.{cache,status} ; \
                $(TARGET_CONFIGURE_OPTS) \
                CFLAGS="$(TARGET_CFLAGS) -DNDEBUG" \
        (cd $(PKG_BUILD_DIR); rm -rf config.{cache,status} ; \
                $(TARGET_CONFIGURE_OPTS) \
                CFLAGS="$(TARGET_CFLAGS) -DNDEBUG" \
-               CPPFLAGS="-I$(STAGING_DIR)/usr/include" \
-               LDFLAGS="-L$(STAGING_DIR)/lib -L$(STAGING_DIR)/usr/lib" \
+               CPPFLAGS="-I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/include" \
+               LDFLAGS="-L$(STAGING_DIR)/usr/lib -L$(STAGING_DIR)/lib" \
                PKG_CONFIG_PATH="$(STAGING_DIR)/usr/lib/pkgconfig" \
                ac_cv_func_malloc_0_nonnull=yes \
                ac_cv_func_realloc_0_nonnull=yes \
                PKG_CONFIG_PATH="$(STAGING_DIR)/usr/lib/pkgconfig" \
                ac_cv_func_malloc_0_nonnull=yes \
                ac_cv_func_realloc_0_nonnull=yes \
@@ -54,18 +54,29 @@ $(PKG_BUILD_DIR)/.configured:
                        --disable-rpath \
                        --with-gnu-ld \
                        --disable-glib \
                        --disable-rpath \
                        --with-gnu-ld \
                        --disable-glib \
+                       --disable-qt3 \
+                       --disable-qt4 \
                        --disable-gtk \
                        --disable-dbus \
                        --enable-expat \
                        --enable-libdaemon \
                        --disable-python \
                        --disable-gtk \
                        --disable-dbus \
                        --enable-expat \
                        --enable-libdaemon \
                        --disable-python \
+                       --disable-pygtk \
+                       --disable-python-dbus \
+                       --disable-mono \
+                       --disable-monodoc \
                        --disable-doxygen-doc \
                        --disable-doxygen-dot \
                        --disable-doxygen-doc \
                        --disable-doxygen-dot \
+                       --disable-doxygen-man \
+                       --disable-doxygen-rtf \
+                       --disable-doxygen-xml \
+                       --disable-doxygen-chm \
+                       --disable-doxygen-chi \
                        --disable-doxygen-html \
                        --disable-doxygen-ps \
                        --disable-doxygen-pdf \
                        --disable-xmltoman \
                        --disable-doxygen-html \
                        --disable-doxygen-ps \
                        --disable-doxygen-pdf \
                        --disable-xmltoman \
-                       --with-distro=openwrt \
+                       --with-distro=none \
                        --with-avahi-user=nobody \
                        --with-avahi-group=nogroup \
        );
                        --with-avahi-user=nobody \
                        --with-avahi-group=nogroup \
        );
@@ -134,8 +145,8 @@ uninstall-dev:
                $(STAGING_DIR)/usr/lib/libavahi-core.so* \
                $(STAGING_DIR)/usr/lib/pkgconfig/avahi-core.pc \
 
                $(STAGING_DIR)/usr/lib/libavahi-core.so* \
                $(STAGING_DIR)/usr/lib/pkgconfig/avahi-core.pc \
 
-compile: install-dev
-clean: uninstall-dev
+compile-targets: install-dev
+clean-targets: uninstall-dev
 
 mostlyclean:
        -$(MAKE) -C $(PKG_BUILD_DIR) clean
 
 mostlyclean:
        -$(MAKE) -C $(PKG_BUILD_DIR) clean