add downloading script (with md5sum checking and sourceforge downloading support)
[openwrt/svn-archive/archive.git] / openwrt / package / iproute2 / Makefile
index 6c786eacfeafd0fdec73f4b921648694ba87648d..313435a47b07c11c07ace4ffa2093e8a0532d877 100644 (file)
@@ -20,7 +20,7 @@ PKG_TC:=$(PACKAGE_DIR)/tc_$(PKG_VERSION)-$(PKG_RELEASE)_$(ARCH).ipk
 PKG_TC_DIR:=$(PKG_BUILD_DIR)/ipkg/tc
 
 $(DL_DIR)/$(PKG_SOURCE):
-        $(WGET) -P $(DL_DIR) $(PKG_SOURCE_URL)/$(PKG_SOURCE)
+        $(SCRIPT_DIR)/download.pl $(DL_DIR) $(PKG_SOURCE) x $(PKG_SOURCE_URL)
 
 $(PKG_BUILD_DIR)/.patched: $(DL_DIR)/$(PKG_SOURCE)
        $(PKG_CAT) $(DL_DIR)/$(PKG_SOURCE) | tar -C $(BUILD_DIR) $(TAR_OPTIONS) -