lots of small package changes and dependency cleanups for the V= stuff
[openwrt/svn-archive/archive.git] / openwrt / package / less / Makefile
index f958ed4205ea3e3ca2440a4d2433b02899590396..51e0a5e482fa72f6921dfa5b128fd9ed105e812b 100644 (file)
@@ -18,7 +18,7 @@ include $(TOPDIR)/package/rules.mk
 
 $(eval $(call PKG_template,LESS,less,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
 
-$(PKG_BUILD_DIR)/.configured: $(PKG_BUILD_DIR)/.prepared
+$(PKG_BUILD_DIR)/.configured:
        (cd $(PKG_BUILD_DIR); rm -rf config.{cache,status} ; \
                $(TARGET_CONFIGURE_OPTS) \
                CFLAGS="-I$(STAGING_DIR)/usr/include $(TARGET_CFLAGS)" \
@@ -50,7 +50,7 @@ $(PKG_BUILD_DIR)/.configured: $(PKG_BUILD_DIR)/.prepared
        );
        touch $@
 
-$(PKG_BUILD_DIR)/.built: $(PKG_BUILD_DIR)/.configured
+$(PKG_BUILD_DIR)/.built:
        $(MAKE) -C $(PKG_BUILD_DIR)
        touch $@