Add some missing headers to STAGING_DIR, required to build php4 extension
[openwrt/svn-archive/archive.git] / openwrt / package / postgresql / Makefile
index de021ba35b23fcfcffe8c69f7eee79a2b3e33564..1f37bb75278df50c20049aa2d1eb3922a06feab2 100644 (file)
@@ -95,6 +95,7 @@ $(IPKG_PGSQL_CLI):
 
 $(STAGING_DIR)/usr/lib/libpq.so: $(PKG_BUILD_DIR)/.built
        mkdir -p $(STAGING_DIR)/usr/include
+       cp -fpR $(PKG_INSTALL_DIR)/usr/include/libpq $(STAGING_DIR)/usr/include/
        cp -fpR $(PKG_INSTALL_DIR)/usr/include/libpq-fe.h $(STAGING_DIR)/usr/include/
        cp -fpR $(PKG_INSTALL_DIR)/usr/include/postgres_ext.h $(STAGING_DIR)/usr/include/
        cp -fpR $(PKG_INSTALL_DIR)/usr/include/postgresql $(STAGING_DIR)/usr/include/
@@ -106,6 +107,7 @@ install-dev: $(STAGING_DIR)/usr/lib/libpq.so
 
 uninstall-dev:
        rm -rf \
+               $(STAGING_DIR)/usr/include/libpq \
                $(STAGING_DIR)/usr/include/libpq-fe.h \
                $(STAGING_DIR)/usr/include/postgres_ext.h \
                $(STAGING_DIR)/usr/include/postgresql \