add downloading script (with md5sum checking and sourceforge downloading support)
[openwrt/svn-archive/archive.git] / openwrt / package / pptpd / Makefile
index a320b15ac67a473fbbe9831e5684e223dfc151ef..5714e4d7865d722c3e47027bd65da4b6128b59be 100644 (file)
@@ -8,7 +8,7 @@ include $(TOPDIR)/rules.mk
 PKG_NAME:=pptpd
 PKG_VERSION:=1.2.3
 PKG_RELEASE:=1
-PKG_SOURCE_URL:=http://unc.dl.sourceforge.net/sourceforge/poptop
+PKG_SOURCE_URL:=@SF/poptop
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
 PKG_CAT:=zcat
@@ -16,7 +16,7 @@ PKG_IPK:=$(PACKAGE_DIR)/$(PKG_NAME)_$(PKG_VERSION)-$(PKG_RELEASE)_$(ARCH).ipk
 PKG_IPK_DIR:=$(PKG_BUILD_DIR)/ipkg
 
 $(DL_DIR)/$(PKG_SOURCE):
-        $(WGET) -P $(DL_DIR) $(PKG_SOURCE_URL)/$(PKG_SOURCE)
+        $(SCRIPT_DIR)/download.pl $(DL_DIR) $(PKG_SOURCE) x $(PKG_SOURCE_URL)
 
 $(PKG_BUILD_DIR)/.unpacked: $(DL_DIR)/$(PKG_SOURCE)
        $(PKG_CAT) $(DL_DIR)/$(PKG_SOURCE) | tar -C $(BUILD_DIR) $(TAR_OPTIONS) -