fix rebuild of pwlib and openh323 after root_clean.
[openwrt/svn-archive/archive.git] / openwrt / package / pwlib / Makefile
index 66e806dc17ad3ca3a705db981875b8620c192e36..68857ff2795af3006504d6798346861c8cb93171 100644 (file)
@@ -88,6 +88,7 @@ $(PKG_BUILD_DIR)/.configured:
                        --disable-wavfile \
                        --disable-xmlrpc \
        );
+       ln -sf $(PKG_NAME)-$(PKG_VERSION) $(BUILD_DIR)/$(PKG_NAME)
        touch $@
 
 $(PKG_BUILD_DIR)/.built:
@@ -96,11 +97,8 @@ $(PKG_BUILD_DIR)/.built:
                optnoshared
        touch $@
 
-install-link:
-       ln -s $(PKG_NAME)-$(PKG_VERSION) $(BUILD_DIR)/$(PKG_NAME)
-
 uninstall-link:
-       rm -rf $(BUILD_DIR)/$(PKG_NAME)
+       rm -f $(BUILD_DIR)/$(PKG_NAME)
 
-compile-targets: $(PKG_BUILD_DIR)/.built install-link
+compile-targets: $(PKG_BUILD_DIR)/.built
 clean-targets: uninstall-link