add swedish webif translation
[openwrt/svn-archive/archive.git] / openwrt / package / rules.mk
index 03b750f50e8dfca0c960b737460c0cb64db8ccaa..267b599a6b54d91c86108805357bdc85880ac9f6 100644 (file)
@@ -1,17 +1,27 @@
+# invoke ipkg with configuration in $(STAGING_DIR)/etc/ipkg.conf 
+IPKG := IPKG_INSTROOT=$(TARGET_DIR) IPKG_CONF_DIR=$(IPKG_CONF) $(SCRIPT_DIR)/ipkg -force-defaults -force-depends
+IPKG_STATE_DIR := $(TARGET_DIR)/usr/lib/ipkg
+
 define PKG_template
 IPKG_$(1):=$(PACKAGE_DIR)/$(2)_$(3)_$(4).ipk
 IDIR_$(1):=$(PKG_BUILD_DIR)/ipkg/$(2)
 INFO_$(1):=$(IPKG_STATE_DIR)/info/$(2).list
 
 ifneq ($(BR2_PACKAGE_$(1)),)
-compile: $$(IPKG_$(1))
+compile-targets: $$(IPKG_$(1))
+endif
+ifneq ($(DEVELOPER),)
+compile-targets: $$(IPKG_$(1))
 endif
 ifeq ($(BR2_PACKAGE_$(1)),y)
-install: $$(INFO_$(1))
+install-targets: $$(INFO_$(1))
 endif
 
+IDEPEND_$(1):=$$(strip $(5))
+
 $$(IDIR_$(1))/CONTROL/control: $(PKG_BUILD_DIR)/.prepared
        $(SCRIPT_DIR)/make-ipkg-dir.sh $$(IDIR_$(1)) ./ipkg/$(2).control $(3) $(4)
+       if [ "$$(IDEPEND_$(1))" != "" ]; then echo "Depends: $$(IDEPEND_$(1))" >> $$(IDIR_$(1))/CONTROL/control; fi
        for file in conffiles preinst postinst prerm postrm; do \
                [ -f ./ipkg/$(2).$$$$file ] && cp ./ipkg/$(2).$$$$file $$(IDIR_$(1))/CONTROL/$$$$file || true; \
        done
@@ -23,8 +33,7 @@ $$(INFO_$(1)): $$(IPKG_$(1))
 
 $(2)-clean:
        rm -f $$(IPKG_$(1))
-clean: $(2)-clean
-
+clean-targets: $(2)-clean
 endef
 
 ifneq ($(strip $(PKG_SOURCE)),)
@@ -45,10 +54,21 @@ endif
 
 all: compile
 
+compile-targets:
+install-targets:
+clean-targets:
+
 source: $(DL_DIR)/$(PKG_SOURCE)
 prepare: $(PKG_BUILD_DIR)/.prepared
-compile:
-install:
+compile: compile-targets
+install: install-targets
+mostlyclean:
+rebuild:
+       -$(MAKE) mostlyclean
+       if [ -f $(PKG_BUILD_DIR)/.built ]; then \
+               $(MAKE) clean; \
+       fi
+       $(MAKE) compile
 
 $(PKG_BUILD_DIR)/.configured: $(PKG_BUILD_DIR)/.prepared
 $(PKG_BUILD_DIR)/.built: $(PKG_BUILD_DIR)/.configured
@@ -56,8 +76,7 @@ $(PKG_BUILD_DIR)/.built: $(PKG_BUILD_DIR)/.configured
 $(PACKAGE_DIR):
        mkdir -p $@
 
-
-clean: 
+clean: clean-targets
        rm -rf $(PKG_BUILD_DIR)
 
 .PHONY: all source prepare compile install clean