fix procmail compile, thx Michael
[openwrt/svn-archive/archive.git] / openwrt / package / rules.mk
index 60584552d729bd9b3d353ea6867f8153c9ce7f9f..9bbf4fa48f89fbac956b4677b3ca56291052d596 100644 (file)
@@ -37,7 +37,7 @@ endef
 
 ifneq ($(strip $(PKG_SOURCE)),)
 $(DL_DIR)/$(PKG_SOURCE):
-       @$(PKG_TRACE) Downloading...
+       @$(CMD_TRACE) "downloading... "
        $(SCRIPT_DIR)/download.pl "$(DL_DIR)" "$(PKG_SOURCE)" "$(PKG_MD5SUM)" $(PKG_SOURCE_URL) $(MAKE_TRACE) 
 endif
 
@@ -45,7 +45,11 @@ ifneq ($(strip $(PKG_CAT)),)
 $(PKG_BUILD_DIR)/.prepared: $(DL_DIR)/$(PKG_SOURCE)
        rm -rf $(PKG_BUILD_DIR)
        mkdir -p $(PKG_BUILD_DIR)
-       $(PKG_CAT) $(DL_DIR)/$(PKG_SOURCE) | tar -C $(PKG_BUILD_DIR)/.. $(TAR_OPTIONS) -
+       if [ "$(PKG_CAT)" = "unzip" ]; then \
+               unzip -d $(PKG_BUILD_DIR) $(DL_DIR)/$(PKG_SOURCE) ; \
+       else \
+               $(PKG_CAT) $(DL_DIR)/$(PKG_SOURCE) | tar -C $(PKG_BUILD_DIR)/.. $(TAR_OPTIONS) - ; \
+       fi                                                
        if [ -d ./patches ]; then \
                $(PATCH) $(PKG_BUILD_DIR) ./patches ; \
        fi
@@ -55,50 +59,46 @@ endif
 all: compile
 
 source: $(DL_DIR)/$(PKG_SOURCE)
-prepare:
+prepare: source
        @[ -f $(PKG_BUILD_DIR)/.prepared ] || { \
-               $(PKG_TRACE) Preparing...; \
+               $(CMD_TRACE) "preparing... "; \
                $(MAKE) $(PKG_BUILD_DIR)/.prepared $(MAKE_TRACE); \
        }
 
-configure:
+configure: prepare
        @[ -f $(PKG_BUILD_DIR)/.configured ] || { \
-               $(PKG_TRACE) Configuring...; \
+               $(CMD_TRACE) "configuring... "; \
                $(MAKE) $(PKG_BUILD_DIR)/.configured $(MAKE_TRACE); \
        }
 
 compile-targets:
-compile:
-       @[ -f $(PKG_BUILD_DIR)/.configured ] || { \
-               $(PKG_TRACE) Configuring...; \
-               $(MAKE) $(PKG_BUILD_DIR)/.configured $(MAKE_TRACE); \
-       }
-       @$(PKG_TRACE) Compiling...
+compile: configure
+       @$(CMD_TRACE) "compiling... " 
        @$(MAKE) compile-targets $(MAKE_TRACE)
 
 install-targets:
 install:
-       @$(PKG_TRACE) Installing...
+       @$(CMD_TRACE) "installing... "
        @$(MAKE) install-targets $(MAKE_TRACE)
 
 mostlyclean:
 rebuild:
-       $(PKG_TRACE) Rebuilding...
+       $(CMD_TRACE) "rebuilding... "
        @-$(MAKE) mostlyclean 2>&1 >/dev/null
        if [ -f $(PKG_BUILD_DIR)/.built ]; then \
                $(MAKE) clean $(MAKE_TRACE); \
        fi
        $(MAKE) compile $(MAKE_TRACE)
 
-$(PKG_BUILD_DIR)/.configured: prepare
-$(PKG_BUILD_DIR)/.built: configure
+$(PKG_BUILD_DIR)/.configured:
+$(PKG_BUILD_DIR)/.built:
 
 $(PACKAGE_DIR):
        mkdir -p $@
 
 clean-targets:
 clean: 
-       @$(PKG_TRACE) Cleaning...
+       @$(CMD_TRACE) "cleaning... " 
        @$(MAKE) clean-targets $(MAKE_TRACE)
        rm -rf $(PKG_BUILD_DIR)