standardize, don't install everything - just the binary,
[openwrt/svn-archive/archive.git] / openwrt / package / wccpd / Makefile
old mode 100755 (executable)
new mode 100644 (file)
index 318a074..044b839
@@ -1,14 +1,17 @@
+# $Id$
+
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=wccpd
 PKG_VERSION:=0.2
 PKG_RELEASE:=1
 PKG_MD5SUM:=5f15c274de61dfb88e0dbfc1ccbe6b67
+
 PKG_SOURCE_URL:=@SF/wccpd
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
 PKG_CAT:=zcat
 
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
 PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
 
 include $(TOPDIR)/package/rules.mk
@@ -17,35 +20,46 @@ $(eval $(call PKG_template,WCCPD,$(PKG_NAME),$(PKG_VERSION)-$(PKG_RELEASE),$(ARC
 
 $(PKG_BUILD_DIR)/.configured:
        (cd $(PKG_BUILD_DIR); rm -rf config.cache; \
-                $(TARGET_CONFIGURE_OPTS) \
-                CFLAGS="$(TARGET_CFLAGS)" \
+               $(TARGET_CONFIGURE_OPTS) \
+               CFLAGS="$(TARGET_CFLAGS)" \
+               CPPFLAGS="-I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/include" \
+               LDFLAGS="-L$(STAGING_DIR)/usr/lib -L$(STAAGING_DIR)/lib" \
                ac_cv_func_setpgrp_void=yes \
-                ./configure \
-                --target=$(GNU_TARGET_NAME) \
-                --host=$(GNU_TARGET_NAME) \
-                --build=$(GNU_HOST_NAME) \
-                --prefix=/usr \
-                --exec-prefix=/usr \
-                --bindir=/usr/bin \
-                --sbindir=/usr/sbin \
-                --libexecdir=/usr/lib \
-                --sysconfdir=/etc \
-                --datadir=/usr/share \
-                --localstatedir=/var \
-                --mandir=/usr/man \
-                               --mandir=/usr/man \
-                --infodir=/usr/info \
-                --program-prefix="" \
-                               --with-gnu-ld \
+               ./configure \
+                       --target=$(GNU_TARGET_NAME) \
+                       --host=$(GNU_TARGET_NAME) \
+                       --build=$(GNU_HOST_NAME) \
+                       --program-prefix="" \
+                       --program-suffix="" \
+                       --prefix=/usr \
+                       --exec-prefix=/usr \
+                       --bindir=/usr/bin \
+                       --datadir=/usr/share \
+                       --includedir=/usr/include \
+                       --infodir=/usr/share/info \
+                       --libdir=/usr/lib \
+                       --libexecdir=/usr/lib \
+                       --localstatedir=/var \
+                       --mandir=/usr/share/man \
+                       --sbindir=/usr/sbin \
+                       --sysconfdir=/etc \
+                       $(DISABLE_LARGEFILE) \
+                       $(DISABLE_NLS) \
+                       --enable-shared \
+                       --enable-static \
+                       --disable-rpath \
+                       --with-gnu-ld \
        );
        touch $@
 
 $(PKG_BUILD_DIR)/.built:
-       $(MAKE) DESTDIR=$(PKG_INSTALL_DIR) -C $(PKG_BUILD_DIR) install
+       $(MAKE) -C $(PKG_BUILD_DIR) \
+               DESTDIR=$(PKG_INSTALL_DIR) \
+               all install
        touch $@
 
 $(IPKG_WCCPD):
-       mkdir -p $(IDIR_WCCPD)
-       cp -fpR $(PKG_INSTALL_DIR)/* $(IDIR_WCCPD)/
+       install -d -m0755 $(IDIR_WCCPD)/usr/sbin
+       cp -fpR $(PKG_INSTALL_DIR)/usr/sbin/wccpd $(IDIR_WCCPD)/usr/sbin/
        $(RSTRIP) $(IDIR_WCCPD)
        $(IPKG_BUILD) $(IDIR_WCCPD) $(PACKAGE_DIR)