disable wap54g images for now
[openwrt/svn-archive/archive.git] / openwrt / target / linux / image / brcm / Makefile
index 01a3cab32d3cfb6b7ad90203682761e1a43dfe75..b15e10b4126498ea9ac26ecae3bf8e5a6845e766 100644 (file)
@@ -25,6 +25,11 @@ endif
 ifeq ($(FS),jffs2-4MB)
 TRXALIGN:=-a 0x10000
 endif
+# see ticket #155
+ifeq ($(FS),squashfs)
+TRXALIGN:=-a 1024
+endif
+
 
 $(KDIR)/loader.tmp.gz:
        cp $(BUILD_DIR)/loader.gz $@
@@ -66,13 +71,13 @@ endif
 ifeq ($(KERNEL),2.4)
 FSNAME:=$(patsubst jffs2-%,jffs2,$(FS))
 
-ifeq ($(FS),squashfs)
-$(BIN_DIR)/openwrt-wap54g-$(KERNEL)-$(FSNAME).trx: $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(FS).trx
-       cp $< $@
-       echo -ne '\x01' >> $@
-       
-install: $(BIN_DIR)/openwrt-wap54g-$(KERNEL)-$(FSNAME).trx
-endif
+ifeq ($(FS),squashfs)
+$(BIN_DIR)/openwrt-wap54g-$(KERNEL)-$(FSNAME).trx: $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(FS).trx
+#      cp $< $@
+#      echo -ne '\x01' >> $@
+#      
+install: $(BIN_DIR)/openwrt-wap54g-$(KERNEL)-$(FSNAME).trx
+endif
 
 ifneq ($(FS),jffs2-8MB)
 $(BIN_DIR)/openwrt-wrt54g3g-$(KERNEL)-$(FSNAME).bin: $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(FS).trx