append a table with offsets for the no-ack and slot timing code to wl.o
[openwrt/svn-archive/archive.git] / openwrt / target / linux / rules.mk
index c9cf9c5e5fce9361b10cee6d214fd6888795e3b4..3358f1fd930acee1911ea9702d5cf5d52ce48345 100644 (file)
@@ -20,6 +20,7 @@ LINUX_KARCH:=$(shell echo $(ARCH) | sed -e 's/i[3-9]86/i386/' \
        -e 's/mipseb/mips/' \
        -e 's/powerpc/ppc/' \
        -e 's/sh[234]/sh/' \
+       -e 's/armeb/arm/' \
 )
 
 KPKG_MAKEOPTS:=        IPKG="$(IPKG_KERNEL)" \
@@ -68,7 +69,7 @@ $$(PKG_$(1)): $(LINUX_DIR)/.modules_done
        echo "Depends: $$(IDEPEND_$(1))" >> $$(I_$(1))/CONTROL/control
 ifneq ($(strip $(3)),)
        mkdir -p $$(I_$(1))/lib/modules/$(LINUX_VERSION)
-       cp $(3) $$(I_$(1))/lib/modules/$(LINUX_VERSION)
+       $(CP) $(3) $$(I_$(1))/lib/modules/$(LINUX_VERSION)
 endif
 ifneq ($(6),)
        mkdir -p $$(I_$(1))/etc/modules.d