add 'OpenWrt-2.0' to gcc version info
[openwrt/svn-archive/archive.git] / openwrt / toolchain / gcc / Makefile
index f6f4acaab63cc067a5b68ecb4e04703b507a1a91..57debe12b82ad4a988bece372168f4d78b43e135 100644 (file)
@@ -79,6 +79,8 @@ ifeq ("$(strip $(ARCH))","armeb")
        $(SCRIPT_DIR)/patch-kernel.sh $(GCC_DIR) ./$(GCC_VERSION) arm-softfloat.patch.conditional
 endif
 endif
+       $(SED) 's,\(version_string.. = "[0-9\.]*\).*\(";\),\1 (OpenWrt-2.0)\2,' $(GCC_DIR)/gcc/version.c
+       $(SED) 's,\(bug_report_url.. = "\).*\(";\),\1<URL:https://dev.openwrt.org/>\2,' $(GCC_DIR)/gcc/version.c
        touch $(GCC_DIR)/.patched
 
 # The --without-headers option stopped working with gcc 3.0 and has never been