fix libgcc handling for gcc 3.4.5 and 4.0.2
[openwrt/svn-archive/archive.git] / openwrt / toolchain / gcc / Makefile
index 57debe12b82ad4a988bece372168f4d78b43e135..642662e8f12e713c2ebcbf3172bb648d3c025aca 100644 (file)
@@ -194,8 +194,8 @@ endif
 # to include a reference to libgcc.so.1 in all binaries. For flash space
 # saving, we change the specs file to link in a static libgcc here. 
        if [ ! -f $(STAGING_DIR)/lib/gcc/$(REAL_GNU_TARGET_NAME)/$(GCC_VERSION)/specs ] ; then \
-               echo staging dir specs file is missing ; \
-               /bin/false ; \
+               echo staging dir specs file is missing, assuming GCC 4.x ; \
+               $(STAGING_DIR)/bin/$(REAL_GNU_TARGET_NAME)-gcc -dumpspecs > $(STAGING_DIR)/lib/gcc/$(REAL_GNU_TARGET_NAME)/$(GCC_VERSION)/specs; \
        fi;
        if grep -q as-needed $(STAGING_DIR)/lib/gcc/$(REAL_GNU_TARGET_NAME)/$(GCC_VERSION)/specs; then \
                patch -d $(STAGING_DIR)/lib/gcc/$(REAL_GNU_TARGET_NAME)/$(GCC_VERSION)/ -p0 < ./$(GCC_VERSION)/static-libgcc.patch.conditional ; \