Toto, we don't support Linux 2.4 anymore..
[openwrt/svn-archive/archive.git] / package / 6in4 / Makefile
index 725c283ded1aa6112b3ccce1afea3391e9d3322e..1f0573b97ad4b61bd90d5df766cf2a96e1f12ba2 100644 (file)
@@ -8,7 +8,7 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=6in4
-PKG_VERSION:=1
+PKG_VERSION:=6
 PKG_RELEASE:=1
 
 include $(INCLUDE_DIR)/package.mk
@@ -18,6 +18,7 @@ define Package/6in4
   CATEGORY:=IPv6
   DEPENDS:=+ip +kmod-ipv6 +kmod-sit
   TITLE:=IPv6-in-IPv4 configuration support
+  MAINTAINER:=Jo-Philipp Wich <xm@subsignal.org>
   PKGARCH:=all
 endef
 
@@ -36,6 +37,8 @@ endef
 define Package/6in4/install
        $(INSTALL_DIR) $(1)/lib/network
        $(INSTALL_DATA) ./files/6in4.sh $(1)/lib/network/6in4.sh
+       $(INSTALL_DIR) $(1)/etc/hotplug.d/iface
+       $(INSTALL_DATA) ./files/6in4.hotplug $(1)/etc/hotplug.d/iface/90-6in4
 endef
 
 $(eval $(call BuildPackage,6in4))