[package] 6in4, 6to4: further simplify protocol backends
[openwrt/svn-archive/archive.git] / package / 6to4 / Makefile
index 95575cf6d04c6692bf2762ecc0cfc710753167b4..740697f75e0cdb160b5bfe3644427e4c38d0aac7 100644 (file)
@@ -8,17 +8,15 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=6to4
-PKG_VERSION:=8
+PKG_VERSION:=9
 PKG_RELEASE:=1
 
-PKG_CONFIG_DEPENDS:=CONFIG_PACKAGE_netifd
-
 include $(INCLUDE_DIR)/package.mk
 
 define Package/6to4
   SECTION:=ipv6
   CATEGORY:=IPv6
-  DEPENDS:=+ip +kmod-ipv6 +kmod-sit
+  DEPENDS:=+kmod-ipv6 +kmod-sit
   TITLE:=IPv6-to-IPv4 configuration support
   MAINTAINER:=Jo-Philipp Wich <xm@subsignal.org>
   PKGARCH:=all
@@ -36,20 +34,9 @@ endef
 define Build/Configure
 endef
 
-ifneq ($(CONFIG_PACKAGE_netifd),)
-  define Package/6to4/install
+define Package/6to4/install
        $(INSTALL_DIR) $(1)/lib/netifd/proto
        $(INSTALL_BIN) ./files/6to4.sh $(1)/lib/netifd/proto/6to4.sh
-       $(INSTALL_DIR) $(1)/etc/hotplug.d/iface
-       $(INSTALL_DATA) ./files/6to4.hotplug $(1)/etc/hotplug.d/iface/91-6to4
-  endef
-else
-  define Package/6to4/install
-       $(INSTALL_DIR) $(1)/lib/network
-       $(INSTALL_DATA) ./files.old/6to4.sh $(1)/lib/network/6to4.sh
-       $(INSTALL_DIR) $(1)/etc/hotplug.d/iface
-       $(INSTALL_DATA) ./files.old/6to4.hotplug $(1)/etc/hotplug.d/iface/91-6to4
-  endef
-endif
+endef
 
 $(eval $(call BuildPackage,6to4))