[ipkg] Generate gzipped package lists
[openwrt/svn-archive/archive.git] / package / Makefile
index 38e39da293be34a3d06fa14c130e2bac472316d5..2a3354cf0adeb28650b2909ad42e608bd1c71c3c 100644 (file)
@@ -1,5 +1,5 @@
-# 
-# Copyright (C) 2006-2007 OpenWrt.org
+#
+# Copyright (C) 2006-2008 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -10,9 +10,16 @@ curdir:=package
 
 -include $(TMP_DIR)/.packagedeps
 $(curdir)/builddirs:=$(sort $(package-) $(package-y) $(package-m))
-$(curdir)/builddirs-default:=. $(sort $(package-y) $(package-m))
-$(curdir)/builddirs-prereq:=. $(sort $(prereq-y) $(prereq-m))
-$(curdir)/builddirs-install:=. $(sort $(package-y))
+ifeq ($(SDK),1)
+  $(curdir)/builddirs-install:=.
+else
+  $(curdir)/builddirs-default:=. $(sort $(package-y) $(package-m))
+  $(curdir)/builddirs-prereq:=. $(sort $(prereq-y) $(prereq-m))
+  $(curdir)/builddirs-install:=. $(sort $(package-y))
+endif
+ifneq ($(IGNORE_ERRORS),)
+  $(curdir)/builddirs-ignore-compile:= $(if $(filter m y, $(IGNORE_ERRORS)),$(foreach m,$(IGNORE_ERRORS),$(package-$(m))),$(package-m))
+endif
 
 $(curdir)/install:=$(curdir)/install-cleanup
 
@@ -20,6 +27,7 @@ $(curdir)/cleanup: $(TMP_DIR)/.build
        rm -rf $(TARGET_DIR)
 
 $(curdir)/rootfs-prepare: $(TMP_DIR)/.build
+       @-$(MAKE) package/preconfig
        @if [ -d $(TOPDIR)/files ]; then \
                $(CP) $(TOPDIR)/files/. $(TARGET_DIR); \
        fi
@@ -34,9 +42,12 @@ $(curdir)/rootfs-prepare: $(TMP_DIR)/.build
        @-find $(TARGET_DIR) -name CVS   | $(XARGS) rm -rf
        @-find $(TARGET_DIR) -name .svn  | $(XARGS) rm -rf
        @-find $(TARGET_DIR) -name '.#*' | $(XARGS) rm -f
+       $(if $(CONFIG_CLEAN_IPKG),rm -rf $(TARGET_DIR)/usr/lib/ipkg)
 
 $(curdir)/index: FORCE
-       @(cd $(PACKAGE_DIR); $(SCRIPT_DIR)/ipkg-make-index.sh . > Packages)
+       @(cd $(PACKAGE_DIR); $(SCRIPT_DIR)/ipkg-make-index.sh . > Packages && \
+               gzip -9c Packages > Packages.gz \
+       )
 
 $(curdir)/flags-install:= -j1