Fix the mac80211 installation, remove the in-kernel mac80211 package, thanks to Danie...
[openwrt/svn-archive/archive.git] / package / Makefile
index 0d74c0d7f35bf9a2813dae20ff8c0ff6c4c25fcd..38b650c09a3becd64e404e52428f015dfdfde910 100644 (file)
@@ -15,34 +15,40 @@ $(curdir)/builddirs-prereq:=. $(sort $(prereq-y) $(prereq-m))
 $(curdir)/builddirs-install:=. $(sort $(package-y))
 
 $(curdir)/install:=$(curdir)/install-cleanup
-$(curdir)/install-cleanup:
-       rm -rf $(BUILD_DIR)/root
-       $(MAKE) install-targets
-       $(MAKE) preconfig
+
+$(curdir)/cleanup: $(TMP_DIR)/.build
+       rm -rf $(TARGET_DIR)
+
+$(curdir)/rootfs-prepare: $(TMP_DIR)/.build
        @if [ -d $(TOPDIR)/files ]; then \
-               $(CP) $(TOPDIR)/files/. $(BUILD_DIR)/root; \
+               $(CP) $(TOPDIR)/files/. $(TARGET_DIR); \
        fi
-       @mkdir -p $(BUILD_DIR)/root/etc/rc.d
+       @mkdir -p $(TARGET_DIR)/etc/rc.d
        @( \
-               cd $(BUILD_DIR)/root; \
+               cd $(TARGET_DIR); \
                for script in ./etc/init.d/*; do \
                        grep '#!/bin/sh /etc/rc.common' $$script >/dev/null || continue; \
-                       IPKG_INSTROOT=$(BUILD_DIR)/root $(which bash) ./etc/rc.common $$script enable; \
+                       IPKG_INSTROOT=$(TARGET_DIR) $(which bash) ./etc/rc.common $$script enable; \
                done || true \
        )
-       @-find $(BUILD_DIR)/root -name CVS   | $(XARGS) rm -rf
-       @-find $(BUILD_DIR)/root -name .svn  | $(XARGS) rm -rf
-       @-find $(BUILD_DIR)/root -name '.#*' | $(XARGS) rm -f
+       @-find $(TARGET_DIR) -name CVS   | $(XARGS) rm -rf
+       @-find $(TARGET_DIR) -name .svn  | $(XARGS) rm -rf
+       @-find $(TARGET_DIR) -name '.#*' | $(XARGS) rm -f
 
 $(curdir)/index: FORCE
-       (cd $(PACKAGE_DIR); $(SCRIPT_DIR)/ipkg-make-index.sh . > Packages)
+       @(cd $(PACKAGE_DIR); $(SCRIPT_DIR)/ipkg-make-index.sh . > Packages)
 
 $(curdir)/flags-install:= -j1
 
 $(eval $(call stampfile,$(curdir),package,prereq))
+$(eval $(call stampfile,$(curdir),package,cleanup))
 $(eval $(call stampfile,$(curdir),package,compile))
 $(eval $(call stampfile,$(curdir),package,install))
+$(eval $(call stampfile,$(curdir),package,rootfs-prepare))
 
-$($(curdir)/stamp-install): $($(curdir)/stamp-compile)
+$($(curdir)/stamp-cleanup): $(TMP_DIR)/.build
+$($(curdir)/stamp-compile): $($(curdir)/stamp-cleanup) $(TMP_DIR)/.build
+$($(curdir)/stamp-install): $($(curdir)/stamp-compile) $(TMP_DIR)/.build
+$($(curdir)/stamp-rootfs-prepare): $($(curdir)/stamp-install) $(TMP_DIR)/.build
 
 $(eval $(call subdir,$(curdir)))