Add build variants support to InstallDev
[openwrt/svn-archive/archive.git] / package / Makefile
index 530405cd06bd9102b0e8f4f74377ae6c44f80563..5468bdc71879df5c378a635e677695810a7f46a4 100644 (file)
@@ -20,9 +20,6 @@ ifneq ($(IGNORE_ERRORS),)
   $(curdir)/builddirs-ignore-compile:= $(if $(filter m y, $(IGNORE_ERRORS)),$(foreach m,$(IGNORE_ERRORS),$(package-$(m))),$(package-m))
 endif
 
-$(curdir)/opkghost: $(TMP_DIR)/.build
-       @-$(MAKE) package/opkg/host/install
-
 $(curdir)/install:=$(curdir)/install-cleanup
 
 $(curdir)/cleanup: $(TMP_DIR)/.build
@@ -91,10 +88,9 @@ $(curdir)/index: FORCE
 $(curdir)/flags-install:= -j1
 
 $(eval $(call stampfile,$(curdir),package,prereq,.config))
-$(eval $(call stampfile,$(curdir),package,cleanup))
-$(eval $(call stampfile,$(curdir),package,compile))
-$(eval $(call stampfile,$(curdir),package,opkghost))
-$(eval $(call stampfile,$(curdir),package,install,$(STAGING_DIR)/stamp/.package_opkghost))
-$(eval $(call stampfile,$(curdir),package,rootfs-prepare))
+$(eval $(call stampfile,$(curdir),package,cleanup,$(TMP_DIR)/.build))
+$(eval $(call stampfile,$(curdir),package,compile,$(TMP_DIR)/.build))
+$(eval $(call stampfile,$(curdir),package,install,$(TMP_DIR)/.build))
+$(eval $(call stampfile,$(curdir),package,rootfs-prepare,$(TMP_DIR)/.build))
 
 $(eval $(call subdir,$(curdir)))