[package] base-files: save the connect time of interfaces in uci state
[openwrt/svn-archive/archive.git] / package / Makefile
index 362a63cc8e6658bd8395debad80a45704725fc1a..786edd49f00955ea114e80caad8347847a9b0f31 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006-2008 OpenWrt.org
+# Copyright (C) 2006-2010 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -17,12 +17,13 @@ else
   $(curdir)/builddirs-install:=. $(sort $(package-y))
 endif
 ifneq ($(IGNORE_ERRORS),)
-  $(curdir)/builddirs-ignore-compile:= $(if $(filter m y, $(IGNORE_ERRORS)),$(foreach m,$(IGNORE_ERRORS),$(package-$(m))),$(package-m))
+  $(curdir)/builddirs-ignore-compile:= $(if $(filter n m y, $(IGNORE_ERRORS)),$(foreach m,$(IGNORE_ERRORS),$(package-$(subst n,,$(m)))),$(package-m) $(package-))
 endif
 
 $(curdir)/install:=$(curdir)/install-cleanup
 
 $(curdir)/cleanup: $(TMP_DIR)/.build
+       - find $(STAGING_DIR_ROOT) -type d | $(XARGS) chmod 0755
        rm -rf $(TARGET_DIR) $(STAGING_DIR_ROOT)
 
 ifdef CONFIG_USE_MKLIBS
@@ -37,13 +38,14 @@ ifdef CONFIG_USE_MKLIBS
                file -r -N -F '' {} + | \
                awk ' /shared object/ { print $$1 }' >> $(TMP_DIR)/mklibs-progs
        mkdir -p $(TMP_DIR)/mklibs-out
-       $(STAGING_DIR_HOST)/bin/mklibs.py -D -v \
+       $(STAGING_DIR_HOST)/bin/mklibs.py -D \
                -d $(TMP_DIR)/mklibs-out \
                --sysroot $(STAGING_DIR_ROOT) \
                -L /lib \
                -L /usr/lib \
+               -L /usr/lib/ebtables \
                --ldlib $(patsubst $(STAGING_DIR_ROOT)/%,/%,$(firstword $(wildcard \
-                       $(foreach name,ld-uClibc.so.* ld-linux.so.*, \
+                       $(foreach name,ld-uClibc.so.* ld-linux.so.* ld-*.so, \
                          $(STAGING_DIR_ROOT)/lib/$(name) \
                        )))) \
                --target $(REAL_GNU_TARGET_NAME) \
@@ -75,7 +77,7 @@ $(curdir)/rootfs-prepare: $(TMP_DIR)/.build
        @-find $(TARGET_DIR) -name CVS   | $(XARGS) rm -rf
        @-find $(TARGET_DIR) -name .svn  | $(XARGS) rm -rf
        @-find $(TARGET_DIR) -name '.#*' | $(XARGS) rm -f
-       $(if $(CONFIG_CLEAN_IPKG),rm -rf $(TARGET_DIR)/usr/lib/ipkg)
+       $(if $(CONFIG_CLEAN_IPKG),rm -rf $(TARGET_DIR)/usr/lib/opkg)
        $(call mklibs)
 
 $(curdir)/index: FORCE