fix typo
[openwrt/svn-archive/archive.git] / package / Makefile
index f5ff8563f38b46da4e2a71fd5601b74040f12c54..c3fc01c7dfed8f053d9f71b202ea35c1ff5ac71a 100644 (file)
@@ -26,9 +26,9 @@ ifeq ($(QUIET),1)
 %-compile %-install: FORCE
        $(MAKE) -C $* $(patsubst $*-%,%,$@) || { $(call MESSAGE, "*** $* $(patsubst $*-%,%,$@) failed"); false; }
 
-%-prereq %-download %-clean: FORCE
+%-prepare %-prereq %-download %-clean: FORCE
 else
-%-prereq %-download %-clean %-compile %-install: FORCE
+%-prepare %-prereq %-download %-clean %-compile %-install: FORCE
 endif
        $(MAKE) -C $* $(patsubst $*-%,%,$@)
 
@@ -58,6 +58,9 @@ install:
                        IPKG_INSTROOT=$(BUILD_DIR)/root $(which bash) ./etc/rc.common $$script enable; \
                done || true \
        )
+       @-find $(BUILD_DIR)/root -name CVS   | $(XARGS) rm -rf
+       @-find $(BUILD_DIR)/root -name .svn  | $(XARGS) rm -rf
+       @-find $(BUILD_DIR)/root -name '.#*' | $(XARGS) rm -f
 
 index: $(PACKAGE_DIR)/Packages