nvram: increase NVRAM size to 64 KiB
[openwrt/svn-archive/archive.git] / package / Makefile
index a6b34be0f485c650971e1771de417ec6aa666cc6..d5212f09a84fd0867fc2498439b2b9de93bec59f 100644 (file)
@@ -143,6 +143,14 @@ $(curdir)/index: FORCE
                $(SCRIPT_DIR)/ipkg-make-index.sh . 2>&1 > Packages && \
                        gzip -9c Packages > Packages.gz; \
        ); done
+ifdef CONFIG_SIGNED_PACKAGES
+       @echo Signing package index...
+       @for d in $(PACKAGE_SUBDIRS); do ( \
+               [ -d $(PACKAGE_DIR)/$$d ] && \
+                       cd $(PACKAGE_DIR)/$$d || continue; \
+               $(STAGING_DIR_HOST)/bin/usign -S -m Packages -s $(BUILD_KEY); \
+       ); done
+else
 ifeq ($(call qstrip,$(CONFIG_OPKGSMIME_KEY)),)
        @echo Signing key has not been configured
 else
@@ -161,6 +169,7 @@ else
        ); done
 endif
 endif
+endif
 
 $(curdir)/preconfig: