fix button-hotplug build on kernel versions where BIT_MASK is not defined (< 2.6.24)
[openwrt/svn-archive/archive.git] / package / Makefile
index 2a3354cf0adeb28650b2909ad42e608bd1c71c3c..e9bed9b6cc174d6c8a1aea94ccc30c975a259127 100644 (file)
@@ -36,7 +36,7 @@ $(curdir)/rootfs-prepare: $(TMP_DIR)/.build
                cd $(TARGET_DIR); \
                for script in ./etc/init.d/*; do \
                        grep '#!/bin/sh /etc/rc.common' $$script >/dev/null || continue; \
-                       IPKG_INSTROOT=$(TARGET_DIR) $(which bash) ./etc/rc.common $$script enable; \
+                       IPKG_INSTROOT=$(TARGET_DIR) $$(which bash) ./etc/rc.common $$script enable; \
                done || true \
        )
        @-find $(TARGET_DIR) -name CVS   | $(XARGS) rm -rf