Apply r12809 to 8.09 branch: Correct /etc/shadow and allow dropbear shadow pwds
[openwrt/svn-archive/archive.git] / package / acx-mac80211 / Makefile
index d2b6d8adb0e839fce983f398847f7da9b7c6ab7f..865719160a6cae5ad84b68ec9abe1fdb671dad81 100644 (file)
@@ -10,20 +10,15 @@ include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/kernel.mk
 
 PKG_NAME:=acx-mac80211
-PKG_VERSION:=20080112
+PKG_REV:=11edba2
+PKG_VERSION:=20080805
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
-PKG_SOURCE_URL:=@SF/acx100
-PKG_MD5SUM:=3d2253c3a639ebccf06113be888118fb
-
-PKG_FW_C16_NAME:=tiacx111c16
-PKG_FW_C16_URL:=http://teknoraver.campuslife.it/software/acx-mac80211/
-PKG_FW_C16_MD5SUM:=7026826460376f6b174f9225bd7781b9
-
-PKG_FW_C19_NAME:=tiacx111c19
-PKG_FW_C19_URL:=http://ipkg.k1k2.de/files/
-PKG_FW_C19_MD5SUM:=a1fa9681e297b4e36e257090fc12265a
+PKG_SOURCE_URL:=git://gitorious.org/acx-mac80211/mainline.git
+PKG_SOURCE_PROTO:=git
+PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
+PKG_SOURCE_VERSION:=$(PKG_REV)
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -39,13 +34,24 @@ define KernelPackage/acx-mac80211/description
        Driver for acx111 cards (Mac80211 version)
 endef
 
-$(STAMP_BUILT): $(DL_DIR)/$(PKG_FW_C16_NAME) $(DL_DIR)/$(PKG_FW_C19_NAME)
 
-$(DL_DIR)/$(PKG_FW_C16_NAME):
-       $(SCRIPT_DIR)/download.pl "$(DL_DIR)" "$(PKG_FW_C16_NAME)" "$(PKG_FW_C16_MD5SUM)" $(PKG_FW_C16_URL)
+C16_FW:=tiacx111c16
+C19_FW:=tiacx111c19
+
+define Download/tiacx111c16
+  FILE:=$(C16_FW)
+  URL:=http://teknoraver.net/software/acx-mac80211/
+  MD5SUM:=7026826460376f6b174f9225bd7781b9
+endef
+$(eval $(call Download,tiacx111c16))
+
+define Download/tiacx111c19
+  FILE:=$(C19_FW)
+  URL:=http://ipkg.k1k2.de/files/
+  MD5SUM:=a1fa9681e297b4e36e257090fc12265a
+endef
+$(eval $(call Download,tiacx111c19))
 
-$(DL_DIR)/$(PKG_FW_C19_NAME):
-       $(SCRIPT_DIR)/download.pl "$(DL_DIR)" "$(PKG_FW_C19_NAME)" "$(PKG_FW_C19_MD5SUM)" $(PKG_FW_C19_URL)
 
 PKG_EXTRA_KCONFIG:= \
        CONFIG_ACX_MAC80211=m \
@@ -73,8 +79,8 @@ endef
 
 define KernelPackage/acx-mac80211/install
        $(INSTALL_DIR) $(1)/lib/firmware
-       $(INSTALL_DATA) $(DL_DIR)/$(PKG_FW_C16_NAME) $(1)/lib/firmware/
-       $(INSTALL_DATA) $(DL_DIR)/$(PKG_FW_C19_NAME) $(1)/lib/firmware/
+       $(INSTALL_DATA) $(DL_DIR)/$(C16_FW) $(1)/lib/firmware/
+       $(INSTALL_DATA) $(DL_DIR)/$(C19_FW) $(1)/lib/firmware/
 endef
 
 $(eval $(call KernelPackage,acx-mac80211))