Use a newer acx firmware
[openwrt/svn-archive/archive.git] / package / acx-mac80211 / Makefile
index 4c96cdf4ab2bb7c6380a9a533b45028bedbe8e5a..ad498824ea984178effb209765dbc7750835e918 100644 (file)
@@ -10,16 +10,20 @@ include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/kernel.mk
 
 PKG_NAME:=acx-mac80211
-PKG_VERSION:=20080112
+PKG_REV:=11edba2
+PKG_VERSION:=20080805
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
-PKG_SOURCE_URL:=@SF/acx100
-PKG_MD5SUM:=3d2253c3a639ebccf06113be888118fb
+PKG_SOURCE_URL:=git://gitorious.org/acx-mac80211/mainline.git
+PKG_SOURCE_PROTO:=git
+PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
+PKG_SOURCE_VERSION:=$(PKG_REV)
 
 PKG_FW_C16_NAME:=tiacx111c16
-PKG_FW_C16_URL:=http://teknoraver.campuslife.it/software/acx-mac80211/
-PKG_FW_C16_MD5SUM:=7026826460376f6b174f9225bd7781b9
+PKG_FW_C16_URL:=http://teknoraver.net/software/acx-mac80211/
+#PKG_FW_C16_MD5SUM:=fcd07de4b25e1d2aaf3b78b27c5b7ee9   #version 1.2.1.34
+PKG_FW_C16_MD5SUM:=7026826460376f6b174f9225bd7781b9    #version 2.3.1.31
 
 PKG_FW_C19_NAME:=tiacx111c19
 PKG_FW_C19_URL:=http://ipkg.k1k2.de/files/
@@ -27,11 +31,10 @@ PKG_FW_C19_MD5SUM:=a1fa9681e297b4e36e257090fc12265a
 
 include $(INCLUDE_DIR)/package.mk
 
-# XXX: remove @!TARGET_* later when we have PCI support properly detected on all targets
 define KernelPackage/acx-mac80211
   SUBMENU:=Wireless Drivers
   TITLE:=ACX111 Mac80211 driver
-  DEPENDS:=+kmod-mac80211 @!TARGET_atheros @!TARGET_uml @BROKEN
+  DEPENDS:=@LINUX_2_6 @PCI_SUPPORT||TARGET_ar7 +kmod-mac80211 @BROKEN
   FILES:=$(PKG_BUILD_DIR)/acx-mac80211.$(LINUX_KMOD_SUFFIX)
   AUTOLOAD:=$(call AutoLoad,50,acx-mac80211)
 endef