massive: replace occurences of .$(LINUX_KMOD_SUFFIX) with .ko after r21950
[openwrt/svn-archive/archive.git] / package / acx / Makefile
index 64725be2650c59700119d229c88a2e5da460a2cd..d910dedcc67553f96fb5c378751589e7da5d0d9a 100644 (file)
@@ -1,5 +1,5 @@
 # 
-# Copyright (C) 2006-2008 OpenWrt.org
+# Copyright (C) 2006-2010 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -10,7 +10,7 @@ include $(INCLUDE_DIR)/kernel.mk
 
 PKG_NAME:=acx
 PKG_VERSION:=20080210
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=@SF/acx100
@@ -25,10 +25,10 @@ include $(INCLUDE_DIR)/package.mk
 
 define KernelPackage/acx
   TITLE:=Driver for TI ACX1xx chipset
-  DEPENDS:=@LINUX_2_6 @TARGET_ar7 +wireless-tools
+  DEPENDS:=@PCI_SUPPORT||TARGET_ar7 +wireless-tools
   URL:=http://acx100.sourceforge.net/
   SUBMENU:=Wireless Drivers
-  FILES:= $(PKG_BUILD_DIR)/acx.$(LINUX_KMOD_SUFFIX)
+  FILES:= $(PKG_BUILD_DIR)/acx.ko
   AUTOLOAD:=$(call AutoLoad,50,acx)
 endef