mac80211: revert the probe request timeout change
[openwrt/svn-archive/archive.git] / package / admswconfig / Makefile
index 0faec37e700a89a7f43e15470e66e3ff46eb884d..6b06cfe6ad97775578c8ba508b3f98af8827dc5a 100644 (file)
@@ -4,7 +4,6 @@
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
@@ -13,7 +12,7 @@ PKG_VERSION:=0.1
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=@openwrt/
+PKG_SOURCE_URL:=http://downloads.openwrt.org/sources
 PKG_MD5SUM:=faafd4618f970119a665b11b21ac6a26
 
 include $(INCLUDE_DIR)/package.mk
@@ -43,6 +42,10 @@ endef
 define Package/admswconfig/install
        $(INSTALL_DIR) $(1)/sbin
        $(INSTALL_BIN) $(PKG_BUILD_DIR)/admswconfig $(1)/sbin/
+       $(INSTALL_DIR) $(1)/lib/network/
+       $(INSTALL_DATA) ./files/admswswitch.sh $(1)/lib/network/admswswitch.sh
+       $(INSTALL_DIR) $(1)/etc/init.d
+       $(INSTALL_BIN) ./files/admswconfig $(1)/etc/init.d/admswconfig
 endef
 
 $(eval $(call BuildPackage,admswconfig))