mac80211: revert the probe request timeout change
[openwrt/svn-archive/archive.git] / package / admswconfig / Makefile
index 609c2e1cf77c87643ddf4ff32ff76f8645b60603..6b06cfe6ad97775578c8ba508b3f98af8827dc5a 100644 (file)
@@ -4,7 +4,6 @@
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id: $
 
 include $(TOPDIR)/rules.mk
 
@@ -13,26 +12,26 @@ PKG_VERSION:=0.1
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=@openwrt/
+PKG_SOURCE_URL:=http://downloads.openwrt.org/sources
 PKG_MD5SUM:=faafd4618f970119a665b11b21ac6a26
 
-PKG_BUILD_DIR := $(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-
 include $(INCLUDE_DIR)/package.mk
 
 define Package/admswconfig
   SECTION:=utils
   CATEGORY:=Utilities
   TITLE:=ADM5120 Switch configuration tool
-  DEPENDS:=@TARGET_ADM5120||TARGET_ADM5120EB
-  DESCRIPTION:=\
-       A program to configure the internal ethernet switch of an ADM5120 processor. \\\
-       You need the corresponding driver for the switch in the kernel. \\\
-       with this program you can configure which ports of the switch belong \\\
-       to the different ethernet devices.
+  DEPENDS:=@TARGET_adm5120
   URL:=http://sharon.esrac.ele.tue.nl/users/pe1rxq/linux-adm/admswconfig/
 endef
 
+define Package/admswconfig/description
+ A program to configure the internal ethernet switch of an ADM5120 processor.
+ You need the corresponding driver for the switch in the kernel. 
+ With this program you can configure which ports of the switch belong 
+ to the different ethernet devices.
+endef
+
 define Build/Configure
 endef
 
@@ -43,6 +42,10 @@ endef
 define Package/admswconfig/install
        $(INSTALL_DIR) $(1)/sbin
        $(INSTALL_BIN) $(PKG_BUILD_DIR)/admswconfig $(1)/sbin/
+       $(INSTALL_DIR) $(1)/lib/network/
+       $(INSTALL_DATA) ./files/admswswitch.sh $(1)/lib/network/admswswitch.sh
+       $(INSTALL_DIR) $(1)/etc/init.d
+       $(INSTALL_BIN) ./files/admswconfig $(1)/etc/init.d/admswconfig
 endef
 
 $(eval $(call BuildPackage,admswconfig))