move ldconfig & ldd to utils section
[openwrt/svn-archive/archive.git] / package / base-files / Makefile
index 437952d72fe1b2b842e611533e8a1677d62c1441..093bf5b984d46372227de4a58d17d7a556866e9f 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2007 OpenWrt.org
+# Copyright (C) 2007-2009 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/kernel.mk
 
 PKG_NAME:=base-files
-PKG_RELEASE:=15
+PKG_RELEASE:=18
 
 PKG_FILE_DEPEND:=$(PLATFORM_DIR)/ $(GENERIC_PLATFORM_DIR)/base-files/
 
@@ -30,6 +30,10 @@ else
   LIBGCC_VERSION:=<LIBGCC_VERSION>
 endif
 
+ifneq ($(LIBC_VERSION),0.9.28)
+  LIBC_VERSION:=$(LIBC_VERSION)$(LIBC_PATCHVER)
+endif
+
 CONFIG_PACKAGE_base-files$(TARGET):=$(CONFIG_PACKAGE_base-files)
 
 define Package/base-files$(TARGET)
@@ -113,12 +117,16 @@ $(call Package/libc/Default)
 endef
 
 define Package/ldd
-$(call Package/uclibc/Default)
+$(call Package/libc/Default)
+  SECTION:=utils
+  CATEGORY:=Utilities
   TITLE:=LDD trace utility
 endef
 
 define Package/ldconfig
 $(call Package/libc/Default)
+  SECTION:=utils
+  CATEGORY:=Utilities
   TITLE:=Shared library path configuration
 endef