[package] base-files: reformat banner to better work with varying version string...
[openwrt/svn-archive/archive.git] / package / base-files / Makefile
index 23bd51a0bd4fd022fdc46af44055ffc7b1953ff1..892a31777c34feb51b853be4483aa9dc2d751a8b 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2007-2011 OpenWrt.org
+# Copyright (C) 2007-2012 OpenWrt.org
 # Copyright (C) 2010 Vertical Communications
 #
 # This is free software, licensed under the GNU General Public License v2.
@@ -8,9 +8,10 @@
 
 include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/kernel.mk
+include $(INCLUDE_DIR)/version.mk
 
 PKG_NAME:=base-files
-PKG_RELEASE:=73
+PKG_RELEASE:=106
 
 PKG_FILE_DEPENDS:=$(PLATFORM_DIR)/ $(GENERIC_PLATFORM_DIR)/base-files/
 PKG_BUILD_DEPENDS:=opkg/host
@@ -34,14 +35,10 @@ endif
 define Package/base-files
   SECTION:=base
   CATEGORY:=Base system
+  DEPENDS:=+!USE_NETIFD:base-files-network +USE_NETIFD:netifd
   TITLE:=Base filesystem for OpenWrt
   URL:=http://openwrt.org/
   VERSION:=$(PKG_RELEASE)-$(REVISION)
-  $(call Config,network.lan.proto,string,static,LAN Protocol)
-  $(call Config,network.lan.ipaddr,ip,192.168.1.1,LAN IP Address)
-  $(call Config,network.lan.netmask,netmask,255.255.255.0,LAN Network Mask)
-  $(call Config,network.lan.gateway,ip,,LAN Gateway)
-  $(call Config,network.lan.dns,ip,,LAN DNS server)
 endef
 
 define Package/base-files/conffiles
@@ -65,6 +62,11 @@ define Package/base-files/description
  This package contains a base filesystem and system scripts for OpenWrt.
 endef
 
+define Package/base-files/config
+  config USE_NETIFD
+    bool "Use netifd instead of the old network init scripts (experimental!)"
+       default n
+endef
 
 define Package/gcc/Default
   SECTION:=libs
@@ -247,6 +249,32 @@ define Package/librt/config
 endef
 
 
+define Package/libgfortran
+$(call Package/gcc/Default)
+  TITLE:=GFortran support library
+  DEPENDS+=@!(TARGET_avr32||TARGET_coldfire) @INSTALL_GFORTRAN
+endef
+
+define Package/libgfortran/config
+       menu "Configuration"
+               depends EXTERNAL_TOOLCHAIN && PACKAGE_libgfortran
+
+       config LIBGFORTRAN_ROOT_DIR
+               string
+               prompt "libgfortran shared library base directory"
+               depends EXTERNAL_TOOLCHAIN && PACKAGE_libgfortran
+               default TOOLCHAIN_ROOT  if !NATIVE_TOOLCHAIN
+               default "/"  if NATIVE_TOOLCHAIN
+
+       config LIBGFORTRAN_FILE_SPEC
+               string
+               prompt "libgfortran shared library files (use wildcards)"
+               depends EXTERNAL_TOOLCHAIN && PACKAGE_libgfortran
+               default "./usr/lib/libgfortran.so.*"
+
+       endmenu
+endef
+
 define Package/ldd
 $(call Package/libc/Default)
   SECTION:=utils
@@ -423,11 +451,14 @@ define Package/base-files/install
        )
 # Form valid /etc/shadow entries, by copying the user:pw pairs
 # from /etc/passwd, and adding on pw change data
-       $(if $(CONFIG_BUSYBOX_CONFIG_FEATURE_SHADOWPASSWDS), \
-               cut -d ':' -f 1-2 $(1)/etc/passwd > $(1)/etc/shadow; \
-               $(SED) 's/$$$$/:13848:0:99999:7:::/' $(1)/etc/shadow \
-       )
-       $(SED) 's,$$$$R,$(REVISION),g' $(1)/etc/banner
+       cut -d ':' -f 1-2 $(1)/etc/passwd > $(1)/etc/shadow; \
+       $(SED) 's/$$$$/:0:0:99999:7:::/' $(1)/etc/shadow
+
+       $(VERSION_SED) \
+               $(1)/etc/banner \
+               $(1)/etc/openwrt_version \
+               $(1)/etc/openwrt_release
+
        mkdir -p $(1)/CONTROL
        mkdir -p $(1)/dev
        mkdir -p $(1)/etc/crontabs
@@ -463,7 +494,12 @@ ifeq ($(CONFIG_EXTERNAL_TOOLCHAIN),)
 
   define Package/libgcc/install
        $(INSTALL_DIR) $(1)/lib
-       $(CP) $(PKG_BUILD_DIR)/libgcc_s.so.* $(1)/lib/
+       $(CP) $(TOOLCHAIN_DIR)/lib/libgcc_s.so.* $(1)/lib/
+  endef
+
+  define Package/libgfortran/install
+       $(INSTALL_DIR) $(1)/usr/lib
+       $(CP) $(TOOLCHAIN_DIR)/lib/libgfortran.so.* $(1)/usr/lib/
   endef
 
   define Package/libssp/install
@@ -482,6 +518,8 @@ ifeq ($(CONFIG_EXTERNAL_TOOLCHAIN),)
 
   define Package/glibc/install
        $(CP) ./glibc-files/* $(1)/
+       rm -f $(1)/etc/localtime
+       ln -sf /tmp/localtime $(1)/etc/localtime
        $(INSTALL_DIR) $(1)/lib
        $(CP) \
                $(TOOLCHAIN_DIR)/lib/ld*.so.* \
@@ -581,6 +619,14 @@ else
        exit 0
   endef
 
+  define Package/libgfortran/install
+       for file in $(call qstrip,$(CONFIG_LIBGFORTRAN_FILE_SPEC)); do \
+               dir=`dirname $$$$file` ; \
+               $(INSTALL_DIR) $(1)/$$$$dir ; \
+               $(CP) $(call qstrip,$(CONFIG_LIBGFORTRAN_ROOT_DIR))/$$$$file $(1)/$$$$dir/ ; \
+       done
+  endef
+
   define Package/libssp/install
        for file in $(call qstrip,$(CONFIG_LIBSSP_FILE_SPEC)); do \
                dir=`dirname $$$$file` ; \
@@ -657,5 +703,6 @@ $(eval $(call BuildPackage,libssp))
 $(eval $(call BuildPackage,libstdcpp))
 $(eval $(call BuildPackage,libpthread))
 $(eval $(call BuildPackage,librt))
+$(eval $(call BuildPackage,libgfortran))
 $(eval $(call BuildPackage,ldd))
 $(eval $(call BuildPackage,ldconfig))