Added identification of WRT610N and its button/led definitions.
[openwrt/svn-archive/archive.git] / package / base-files / Makefile
index c47a0f8ba4cb3a40923756dff9a8b5ebee9e2bdb..92257d8011071e13b05c6c488963b00db4023c19 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/kernel.mk
 
 PKG_NAME:=base-files
-PKG_RELEASE:=18
+PKG_RELEASE:=26
 
 PKG_FILE_DEPENDS:=$(PLATFORM_DIR)/ $(GENERIC_PLATFORM_DIR)/base-files/
 
@@ -24,14 +24,15 @@ ifneq ($(DUMP),1)
   ifeq ($(ARCH),x86_64)
     LIB_SUFFIX:=64
   endif
+  ifneq ($(findstring mips64,$(ARCH)),)
+    LIB_SUFFIX:=64
+  endif
 else
   LIBC_VERSION:=<LIBC_VERSION>
   LIBGCC_VERSION:=<LIBGCC_VERSION>
 endif
 
-CONFIG_PACKAGE_base-files$(TARGET):=$(CONFIG_PACKAGE_base-files)
-
-define Package/base-files$(TARGET)
+define Package/base-files
   SECTION:=base
   CATEGORY:=Base system
   TITLE:=Base filesystem for OpenWrt
@@ -44,7 +45,7 @@ define Package/base-files$(TARGET)
   $(call Config,network.lan.dns,ip,,LAN DNS server)
 endef
 
-define Package/base-files$(TARGET)/conffiles
+define Package/base-files/conffiles
 /etc/banner
 /etc/hosts
 /etc/inittab
@@ -56,7 +57,7 @@ define Package/base-files$(TARGET)/conffiles
 $(call $(TARGET)/conffiles)
 endef
 
-define Package/base-files$(TARGET)/description
+define Package/base-files/description
  This package contains a base filesystem and system scripts for OpenWrt.
 endef
 
@@ -71,7 +72,7 @@ endef
 define Package/libgcc
 $(call Package/gcc/Default)
   TITLE:=GCC support library
-  DEPENDS+=@!TARGET_avr32
+  DEPENDS+=@!(TARGET_avr32||TARGET_coldfire)
 endef
 
 define Package/libssp
@@ -137,7 +138,7 @@ define Build/Compile
        $(call Build/Compile/Default)
 endef
 
-define Package/base-files$(TARGET)/install
+define Package/base-files/install
        $(CP) ./files/* $(1)/
        if [ -d $(GENERIC_PLATFORM_DIR)/base-files/. ]; then \
                $(CP) $(GENERIC_PLATFORM_DIR)/base-files/* $(1)/; \
@@ -172,12 +173,15 @@ define Package/base-files$(TARGET)/install
        mkdir -p $(1)/CONTROL
        mkdir -p $(1)/dev
        mkdir -p $(1)/etc/crontabs
+       mkdir -p $(1)/etc/rc.d
        mkdir -p $(1)/jffs
        mkdir -p $(1)/lib/firmware
+       $(if $(LIB_SUFFIX),-ln -s lib $(1)/lib$(LIB_SUFFIX))
        mkdir -p $(1)/mnt
        mkdir -p $(1)/proc
        mkdir -p $(1)/tmp
        mkdir -p $(1)/usr/lib
+       $(if $(LIB_SUFFIX),-ln -s lib $(1)/usr/lib$(LIB_SUFFIX))
        mkdir -p $(1)/usr/bin
        mkdir -p $(1)/sys
        mkdir -p $(1)/www
@@ -241,6 +245,10 @@ define Package/libc/install
 $(call Package/$(LIBC)/install,$1)
 endef
 
+define Package/libc/install_lib
+       $(CP) $(filter-out %/libdl_pic.a,$(wildcard $(TOOLCHAIN_DIR)/usr/lib/lib*.a)) $(1)/lib/
+endef
+
 define Package/libpthread/install
        $(INSTALL_DIR) $(1)/lib
        $(CP) $(TOOLCHAIN_DIR)/lib/libpthread.so.* $(1)/lib/
@@ -267,7 +275,7 @@ ifneq ($(DUMP),1)
   -include $(PLATFORM_DIR)/base-files.mk
 endif
 
-$(eval $(call BuildPackage,base-files$(TARGET)))
+$(eval $(call BuildPackage,base-files))
 $(eval $(call BuildPackage,libc))
 $(eval $(call BuildPackage,libgcc))
 $(eval $(call BuildPackage,libssp))