uclibc: to rebuild libc.so.0, mklibs.py needs access to libc_so.a which was not expor...
[openwrt/svn-archive/archive.git] / package / base-files / Makefile
index fb7debf96c4ee36f492877b7d0a1ae301109cdd9..9e395bf199db5e64d7a283ef2ce7a5e9076d1104 100644 (file)
@@ -32,9 +32,7 @@ else
   LIBGCC_VERSION:=<LIBGCC_VERSION>
 endif
 
-CONFIG_PACKAGE_base-files$(TARGET):=$(CONFIG_PACKAGE_base-files)
-
-define Package/base-files$(TARGET)
+define Package/base-files
   SECTION:=base
   CATEGORY:=Base system
   TITLE:=Base filesystem for OpenWrt
@@ -47,7 +45,7 @@ define Package/base-files$(TARGET)
   $(call Config,network.lan.dns,ip,,LAN DNS server)
 endef
 
-define Package/base-files$(TARGET)/conffiles
+define Package/base-files/conffiles
 /etc/banner
 /etc/hosts
 /etc/inittab
@@ -59,7 +57,7 @@ define Package/base-files$(TARGET)/conffiles
 $(call $(TARGET)/conffiles)
 endef
 
-define Package/base-files$(TARGET)/description
+define Package/base-files/description
  This package contains a base filesystem and system scripts for OpenWrt.
 endef
 
@@ -140,7 +138,7 @@ define Build/Compile
        $(call Build/Compile/Default)
 endef
 
-define Package/base-files$(TARGET)/install
+define Package/base-files/install
        $(CP) ./files/* $(1)/
        if [ -d $(GENERIC_PLATFORM_DIR)/base-files/. ]; then \
                $(CP) $(GENERIC_PLATFORM_DIR)/base-files/* $(1)/; \
@@ -249,6 +247,8 @@ endef
 
 define Package/libc/install_lib
        $(CP) $(filter-out %/libdl_pic.a,$(wildcard $(TOOLCHAIN_DIR)/usr/lib/lib*.a)) $(1)/lib/
+       $(if $(wildcard $(TOOLCHAIN_DIR)/usr/lib/libc_so.a),$(CP) $(TOOLCHAIN_DIR)/usr/lib/libc_so.a $(1)/lib/libc_pic.a)
+       $(CP) $(TOOLCHAIN_DIR)/usr/lib/gcc/*/*/libgcc.a $(1)/lib/libgcc_s_pic.a
 endef
 
 define Package/libpthread/install
@@ -277,7 +277,7 @@ ifneq ($(DUMP),1)
   -include $(PLATFORM_DIR)/base-files.mk
 endif
 
-$(eval $(call BuildPackage,base-files$(TARGET)))
+$(eval $(call BuildPackage,base-files))
 $(eval $(call BuildPackage,libc))
 $(eval $(call BuildPackage,libgcc))
 $(eval $(call BuildPackage,libssp))