fstools: scripts should propagate the cmdline
[openwrt/svn-archive/archive.git] / package / base-files / Makefile
index 050cc77b51749a331c25b5664642f2994e23ef5c..d0366eeab3315fbca079ca156cb3e13d434b605f 100644 (file)
@@ -7,15 +7,14 @@
 #
 
 include $(TOPDIR)/rules.mk
-include $(INCLUDE_DIR)/kernel.mk
 include $(INCLUDE_DIR)/version.mk
+include $(INCLUDE_DIR)/kernel.mk
 
 PKG_NAME:=base-files
-PKG_RELEASE:=138
+PKG_RELEASE:=151
 
 PKG_FILE_DEPENDS:=$(PLATFORM_DIR)/ $(GENERIC_PLATFORM_DIR)/base-files/
 PKG_BUILD_DEPENDS:=opkg/host
-PKG_CONFIG_DEPENDS:=CONFIG_PROCD_INIT
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -56,18 +55,6 @@ define Package/base-files/description
  This package contains a base filesystem and system scripts for OpenWrt.
 endef
 
-define Package/base-files/config
-config PROCD_INIT
-       bool "Use procd as the init process"
-       default n
-endef
-
-ifeq ($(CONFIG_PROCD_INIT),)
-define InstallOldFiles
-       $(CP) ./files.old/* $(1)/
-endef
-endif
-
 ifneq ($(CONFIG_PREINITOPT),)
 define ImageConfigOptions
        mkdir -p $(1)/lib/preinit
@@ -100,7 +87,6 @@ define Package/base-files/install
        if [ -d $(GENERIC_PLATFORM_DIR)/base-files/. ]; then \
                $(CP) $(GENERIC_PLATFORM_DIR)/base-files/* $(1)/; \
        fi
-       $(call InstallOldFiles,$(1))
        if [ -d $(PLATFORM_DIR)/base-files/. ]; then \
                $(CP) $(PLATFORM_DIR)/base-files/* $(1)/; \
        fi