projects
/
openwrt
/
svn-archive
/
archive.git
/ blobdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
|
commitdiff
|
tree
raw
|
inline
| side by side
use separate sysctl.conf files for 2.4 and 2.6 - fixes some boot message spam
[openwrt/svn-archive/archive.git]
/
package
/
base-files
/
Makefile
diff --git
a/package/base-files/Makefile
b/package/base-files/Makefile
index 1e1610c5d739fa92e473521902aedd67412de9ba..e267b7f78b67bb876e7735f796c660877bf9dea3 100644
(file)
--- a/
package/base-files/Makefile
+++ b/
package/base-files/Makefile
@@
-13,7
+13,7
@@
PKG_NAME:=base-files
PKG_RELEASE:=8
PKG_BUILD_DIR:=$(KERNEL_BUILD_DIR)/$(PKG_NAME)
PKG_RELEASE:=8
PKG_BUILD_DIR:=$(KERNEL_BUILD_DIR)/$(PKG_NAME)
-PKG_FILE_DEPEND:=$(PLATFORM_DIR)
+PKG_FILE_DEPEND:=$(PLATFORM_DIR)
$(GENERIC_PLATFORM_DIR)/base-files
REV:=$(shell LANG=C svn info | awk '/^Revision:/ { print$$2 }' )
ifeq ($(REV),)
REV:=$(shell LANG=C svn info | awk '/^Revision:/ { print$$2 }' )
ifeq ($(REV),)
@@
-110,6
+110,9
@@
endef
define Package/base-files$(TARGET)/install
$(CP) ./files/* $(1)/
define Package/base-files$(TARGET)/install
$(CP) ./files/* $(1)/
+ if [ -d $(GENERIC_PLATFORM_DIR)/base-files/. ]; then \
+ $(CP) $(GENERIC_PLATFORM_DIR)/base-files/* $(1)/; \
+ fi
if [ -d $(PLATFORM_DIR)/base-files/default/. ]; then \
$(CP) $(PLATFORM_DIR)/base-files/default/* $(1)/; \
fi
if [ -d $(PLATFORM_DIR)/base-files/default/. ]; then \
$(CP) $(PLATFORM_DIR)/base-files/default/* $(1)/; \
fi